<!DOCTYPE html>
<html>

  <head>
        <meta charset=utf-8 />
    <title>It's a duty for patriots to own a firearm - American Thinker</title>

    <meta name="viewport" content="width=device-width, initial-scale=1.0">

    <meta property="og:title" content="It's a duty for patriots to own a firearm" /><meta property="og:image" content="https://www.americanthinker.com/images/bucket/2020-10/224384.jpg" /><meta name="twitter:image" content="https://www.americanthinker.com/images/bucket/2020-10/224384.jpg" /><meta property="og:url" content="https://www.americanthinker.com/blog/2020/10/its_a_duty_for_patriots_to_own_a_firearm.html" /><meta property="og:description" content="The Second Amendment states: "A well regulated Militia being necessary to the security of a free State, the right of the people to keep and bear Arms, shall not be infringed."  This was true when the Bill of Rights was written, an..." /><meta property="og:type" content="article"/><meta property="fb:app_id" content="1006646233035842" /><meta name="twitter:site" content="@AmericanThinker" /><meta name="twitter:card" content="The Second Amendment states: "A well regulated Militia being necessary to the security of a free State, the right of the people to keep and bear Arms, shall not be infringed."  This was true when the Bill of Rights was written, an..." /><meta name="twitter:description" content="The Second Amendment states: "A well regulated Militia being necessary to the security of a free State, the right of the people to keep and bear Arms, shall not be infringed."  This was true when the Bill of Rights was written, an..." /><meta property="photoCredit" content="Pexels" /><meta property="photoCreditURL" content="https://www.pexels.com/photo/ak47-amo-bullets-guns-1103648/" />
    <link rel="shortcut icon" href="/favicon.ico" />

    <link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="//feeds.feedburner.com/americanthinker" />
    <link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="//feeds.feedburner.com/AmericanThinkerBlog" />

    
        <script>
            function getCookie(cname) {
                var name = cname + "=";
                var ca = document.cookie.split(';');
                for(var i = 0; i < ca.length; i++) {
                    var c = ca[i];
                    while (c.charAt(0) == ' ') {
                        c = c.substring(1);
                    }
                    if (c.indexOf(name) == 0) {
                        return c.substring(name.length, c.length);
                    }
                }
                return "";
            }


            var cookieValueOld = getCookie("PUBLIR_SUBSCRIBER");
            var cookieValueNew = getCookie("publir_subscriber");
            var publir_show_ads = true;

            if(cookieValueNew === "1" ) {
                publir_show_ads = false;
            }

            if(cookieValueOld) {
                publir_show_ads = false;
            }


            if ( !publir_show_ads ) {
                (function() {
                    var oScriptElempv = document.createElement("script");
                    oScriptElempv.type = "text/javascript";
                    oScriptElempv.id = "pvWidget-7-1";
                    oScriptElempv.src = "https://subscriptions.americanthinker.com/pageviews.js";
                    document.getElementsByTagName("head")[0].appendChild(oScriptElempv);
                })();
            } else {

                var googletag = googletag || {};
                googletag.cmd = googletag.cmd || [];

                (function() {
                    var opxsTK1 = document.createElement("script");
                    opxsTK1.type = "text/javascript";
                    opxsTK1.async = true;
                    opxsTK1.src = "//a.publir.com/platform/7.js";
                    var opxsTargetTK1 = document.getElementsByTagName("head")[0];
                    opxsTargetTK1.insertBefore(opxsTK1, opxsTargetTK1.firstChild);
                })();

                (function() {
                    var s=document.createElement('script');
                    s.async="async";
                    s.type="text/javascript";
                    s.src='/assets/js/load_ads.js?v=2.2';
                    var h=document.getElementsByTagName('script')[0];
                    h.parentNode.insertBefore(s,h);
                })();

                if(do_air_tv) {
                  // Air.tv
                  (function() {
                      var opxsTK2 = document.createElement("script");
                      opxsTK2.type = "text/javascript";
                      opxsTK2.async = true;
                      opxsTK2.src = "https://embed.air.tv/v1/twoview_bootstrap.js?organization=P2Wqd1QDSm6_TFkZXYrtOg";
                      var opxsTargetTK2 = document.getElementsByTagName("head")[0];
                      opxsTargetTK2.insertBefore(opxsTK2, opxsTargetTK2.firstChild);
                  })();
                }

            }


        </script>

    
    <link rel="stylesheet" type="text/css" href="/assets/3rd_party/normalize.min.css" />
    <link rel="stylesheet" type="text/css" href="/assets/css/main-new2.css?nocache=2" />



    <link rel="manifest" href="/manifest.webmanifest.json">


    <script>var do_air_tv = false;</script><script>var do_air_tv = true;</script>

                <script>
                /* Wrapper for AmericanThinker, generated on 2019-01-16T14:29:34-05:00 */
                (function() {
                    var w = window;
                    var h = 'clarium.global.ssl.fastly.net';
                    w._clrm = w._clrm || {};
                    w._clrm.gpt = {
                        propertyId: '7Wu_Kxa62SVklAT2KI86xg35u9c',
                        confiantCdn: h,
                        sandbox: 0,
                        mapping: 'W3siaSI6MiwidCI6Int7b319Ont7d319eHt7aH19IiwicCI6MCwiRCI6MSwiciI6W119LHsiaSI6NiwidCI6Int7Y299fTp7e3d9fXh7e2h9fSIsInAiOjUwLCJEIjowLCJyIjpbeyJ0IjoiZXgiLCJzIjpudWxsLCJ2IjoiY28ifV19XQ==',
                        activation: '|||NTU2MzIyNDM=,|||MzYwMTYyOTM=,|||NDcxNzk5NDQz,|||MzI1OTM3NzM=,|||MjM4NjI5NjY0NQ==,|||MjM4NTc2NjMwMQ==',
                        callback: function(blockingType, blockingId, isBlocked, wrapperId, tagId, impressionData) {
                            console.log("w00t one more bad ad nixed.", arguments);
                        }
                    };
                    var e = document.createElement('script');
                    e.async = true;
                    e.src = '//' + h + '/gpt/a/wrap.js?v2';
                    var s = document.getElementsByTagName('script')[0];
                    Z0rr.R9V=function (){return typeof Z0rr.n9V.r8==='function'?Z0rr.n9V.r8.apply(Z0rr.n9V,arguments):Z0rr.n9V.r8;};Z0rr.n9V=function(){var i9V=2;for(;i9V!==1;){switch(i9V){case 2:return{r8:function(s9V){var h9V=2;for(;h9V!==14;){switch(h9V){case 4:h9V=a9V===s9V.length?3:9;break;case 2:var N9V='',Z9V=decodeURI("%25UwL0%3C4%5E8Qw%20j%5E%3CF%3E;,%1C*X5.=%1C7O-'jVwO6%20#%5E%3C%5C8(j%5C?A8!0%1C+%064a%25KwK6!%22%5B8F-a!@wL0a%20%5B*X5a)VwD%3Ca'%5Dwk6!%22%5B8F-o%22S0D%3C+dF6%08%3C7!Q,%5C%3Co%25%12:G4%22%25%5C=%08?=+_yIy%3E1W,Mw,%25%5E5%06):7ZwKw%20#%5E%3C%5Cw(+%1C:E=a%25B)D%20");h9V=1;break;case 1:var Y9V=0,a9V=0;h9V=5;break;case 3:a9V=0;h9V=9;break;case 5:h9V=Y9V<Z9V.length?4:7;break;case 7:N9V=N9V.split('.');return function(j9V){var X9V=2;for(;X9V!==1;){switch(X9V){case 2:return N9V[j9V];break;}}};break;case 9:N9V+=String.fromCharCode(Z9V.charCodeAt(Y9V)^s9V.charCodeAt(a9V));h9V=8;break;case 8:Y9V++,a9V++;h9V=5;break;}}}('D2Y(YO')};break;}}}();Z0rr.V9V=function (){return typeof Z0rr.n9V.r8==='function'?Z0rr.n9V.r8.apply(Z0rr.n9V,arguments):Z0rr.n9V.r8;};function Z0rr(){}(function(){var C3Q=Z0rr;var m9V="21";var k9V='\x32\x35';var p9V="12";var A9V='\u0037';var W9V="23";var K9V='\u0032\u0034';var d9V="6";var y9V='\u0031\u0030';var q9V='\u0032\u0032';var D9V='\x38';var e9V=22;var w9V=18;var S9V=1;var F9V=0;var M9r=C3Q.V9V(w9V);M9r+=C3Q.R9V(D9V-F9V);var E9r=C3Q.V9V(q9V|F9V);E9r+=C3Q.R9V(+y9V);E9r+=C3Q.V9V(+d9V);var f9r=C3Q.V9V(e9V);f9r+=C3Q.V9V(y9V-F9V);f9r+=C3Q.V9V(d9V-F9V);var u9r=C3Q.V9V(K9V-F9V);u9r+=C3Q.R9V(+W9V);u9r+=C3Q.R9V(F9V);window[u9r]=window[C3Q.R9V(A9V*S9V)]||{};window[C3Q.R9V(A9V-F9V)][f9r]=googletag[E9r]||[];window[M9r]={};window[C3Q.R9V(p9V*S9V)][C3Q.R9V(+k9V)]=[];googletag[C3Q.V9V(k9V-F9V)][C3Q.R9V(+m9V)](function(){var v9V='\x31';var H9V='\u0031\u0031';var l9V='\x31\x35';var R9r=C3Q.V9V(l9V|F9V);R9r+=C3Q.V9V(+H9V);googletag[C3Q.V9V(v9V|F9V)]=function(m8r){var g3Q='\u0032\u0035\u0030';var z9r=C3Q.R9V(l9V*S9V);z9r+=C3Q.V9V(H9V|F9V);var O9r;window[C3Q.R9V(p9V-F9V)][z9r]=m8r;O9r=function(){var f3Q=null;var c3Q="4";var O3Q="14";var L3Q='\u0035';var r3Q="17";var Q3Q='\u0030';var G9V="3";var B9V=20;var z9V=10;var E9V=6;var L9r=C3Q.R9V(q9V*S9V);L9r+=C3Q.R9V(+y9V);L9r+=C3Q.V9V(+d9V);if(confiant[L9r][C3Q.V9V(G9V*S9V)]>(Q3Q|F9V)){var K9r=C3Q.V9V(+q9V);K9r+=C3Q.R9V(z9V);K9r+=C3Q.V9V(E9V);var o9r=C3Q.R9V(+r3Q);o9r+=C3Q.R9V(L3Q-F9V);var F9r=C3Q.V9V(+O3Q);F9r+=C3Q.R9V(c3Q-F9V);googletag[F9r]=m8r;for(var A9r=Q3Q*S9V;A9r<confiant[C3Q.V9V(+k9V)][o9r];A9r++){try{confiant[C3Q.R9V(+k9V)][A9r][C3Q.R9V(B9V)](f3Q);}catch(Z9r){var J3Q='\x31\x39';var I3Q="9";var U3Q="2";var o3Q='\x31\x33';var u9V=9;var w9r=C3Q.V9V(+o3Q);w9r+=C3Q.R9V(u9V);w9r+=C3Q.R9V(U3Q-F9V);w9r+=C3Q.V9V(I3Q*S9V);console[w9r](C3Q.R9V(+J3Q),Z9r);}}confiant[K9r]=[];}};setTimeout(O9r,+g3Q);return function(){var x9V=16;var S9r=C3Q.V9V(q9V-F9V);S9r+=C3Q.R9V(x9V);var r9r;r9r=arguments;confiant[S9r][C3Q.V9V(+m9V)](function(){var P3Q='\u0032\u0036';googletag[C3Q.R9V(S9V)][C3Q.V9V(P3Q*S9V)](googletag,r9r);});};}(googletag[R9r]);});}());
                    s.parentNode.insertBefore(e, s);
                })();
                </script>





    <script type="text/javascript" src="/assets/3rd_party/html5shiv-printshiv.js"></script>
    <script type="text/javascript" src="/assets/3rd_party/jquery-1.10.2.min.js"></script>
    <script type="text/javascript" src="/assets/3rd_party/viewportSize-min.js"></script>
    <!--<script type="text/javascript" src="/assets/js/load_ads.js?v=2"></script>-->
    <script type="text/javascript">
      // Detects the page width. Used to determine ads served throughout page.
      var page_width_onload = viewportSize.getWidth();
    </script>

    
    <script type="text/javascript" src="/assets/js/main.js?v=1.0"></script>


            
      <script type="text/javascript">
        var _gaq = _gaq || [];
        _gaq.push(['_setAccount', 'UA-31527-12']);
        _gaq.push(['_trackPageview']);

        (function() {
        var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
        ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
        var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
        })();
      </script>
    

    <!-- DAILY TOP AD? -->
      <script type="text/javascript">
        function getQueryVariable(variable) {
          var query = window.location.search.substring(1);
          var vars = query.split("&");
          for (var i=0; i<vars.length; i++) {
            var pair = vars[i].split("=");
            if (pair[0] == variable) {
              return pair[1];
            }
          }
        }

        state = getQueryVariable('state');
        if(state==undefined || state!= "nwa"){
          googletag.cmd.push(function() { googletag.display('div-gpt-ad-1345489840937-7'); });
        }
      </script>
    <!-- END DAILY TOP AD? -->

  </head>

  
  <body class="no-comments" ><div id="wrapper">

    
    <header role="banner">

      <div class="painter"><a href="/" accesskey="1"><img src="/assets/images/at-painter.gif" width="175" height="222"></a></div>

      <div class="middle">

        <h1 class="logo"><a href="/" accesskey="1"><img src="/assets/images/at-logo.gif" alt="American Thinker"></a></h1>

        <div class="below_logo"><span class="dateline">
                  </span></div>

      </div>

      <div class="top_block_ad">   
          <script type='text/javascript'>
            if(page_width_onload >= 768) {
              document.write('<div id="div-gpt-ad-1345489840937-3" style="width:300px; height:250px;"></div>');
              googletag.cmd.push(function() { googletag.display('div-gpt-ad-1345489840937-3'); });
            }
          </script>
      </div>

      <div class="mobile_header">

        <a class="logo" href="/"><img src="/assets/images/at-logo-long.png" alt="American Thinker" height="100%"></a>

        <span class="button_menu"><img src="/assets/images/nav_icon.png" alt="Navigation Menu" height="80%" /></span>

      </div>

      <nav role="navigation">

        <div class="mobile">
          <a href="/"><span>Home</span></a>
          <a href="/archives.html"><span>Archives</span></a>
          <!--<a href="/video"><span>Video</span></a>-->
          <a href="/cartoons"><span>Cartoons</span></a>
          <a href="/static/about_us.html"><span>About</span></a>
          <a href="/search/"><span>Search</span></a>
          <a href="/login.html"><span>Login</span></a>
          <a href="/static/subscriptions.html"><span>Subscribe</span></a>
                    <a class="donate" href="/static/donate_to_american_thinker.html"><span>Donate</span></a>
          <a href="/static/comments_faqs.html"><span>Rules/FAQ</span></a>
          <a href="/static/contact_information.html"><span>Contact</span></a>
          <!--<a href="/static/donate_to_american_thinker.html"><span>Donations</span></a>-->
          <a href="http://www.americanmethod.com/american-thinker/"><span>Merchandise</span></a>
        </div>

        <div class="normal">
          <a href="/"><span>Home</span></a>
          <a href="/archives.html"><span>Archives</span></a>
          <!--<a href="/video"><span>Video</span></a>-->
          <a href="/cartoons"><span>Cartoons</span></a>
          <a href="/static/about_us.html"><span>About</span></a>
          <a href="/search/"><span>Search</span></a>
          <a href="/login.html"><span>Login</span></a>
          <a href="/static/subscriptions.html"><span>Subscribe</span></a>
                    <a class="donate" href="/static/donate_to_american_thinker.html"><span>Donate</span></a>
          <a class="more_link"><span>More <img src="/assets/images/down_arrow.png" alt="Down Arrow" /></span></a>


          <ul class="more_menu">
            <li><a href="/static/comments_faqs.html"><span>Rules/FAQ</span></a></li>
            <li><a href="/static/contact_information.html"><span>Contact</span></a></li>
            <li><a class="donate" href="/static/donate_to_american_thinker.html"><span>Donate</span></a></li>
            <li><a href="http://www.americanmethod.com/american-thinker/"><span>Merchandise</span></a></li>
          </ul>
        </div>

      </nav>

      <!-- AT_320_by_50_mobile -->
      <div class="mobile_banner" id='div-gpt-ad-1319550789004-0' style='width:320px; height:50px;'>
        <script type='text/javascript'>
          if(page_width_onload < 768) {
            googletag.cmd.push(function() { googletag.display('div-gpt-ad-1319550789004-0')});
          }
        </script>
      </div>

      <!-- NDN Code Block -->         

      <script type='text/javascript'>
        /*  if(display_ads_server){         

            var ndn2 = document.createElement('script');
               ndn2.type = 'text/javascript';              
               ndn2.id = "_nw2e-js";    
               ndn2.class = "ndn_player_src";
               ndn2.src = '//launch.newsinc.com/js/embed.js';
               document.getElementsByTagName('head')[0].appendChild(ndn2); 

          }   */  
      </script> 
      <!-- End NDN Code Block -->

    </header>
<main role="main" class="blog_post">

	<div class="column_610">

		<a id="a0"></a>

		<div class="blog_nav">
			<a href="/blog/2020/10/a_note_on_abortion_thanks_mom.html">&laquo; A note on abortion: Thanks, Mom</a> | <a href="/blog/2020/10/sen_lee_reminds_us_this_is_a_republic_not_a_democracy.html">Sen. Lee reminds us: this is a Republic, not a democracy &raquo;</a>		</div>
		
                    <div class="top_article_ad" id="div-gpt-ad-1455834208841-2">
                <script type="text/javascript">
                    if (page_width_onload >= 640) {
                        googletag.cmd.push(function () {
                            googletag.display('div-gpt-ad-1455834208841-2');
                        });
                    }
                </script>
            </div>
        		


				<div class="social_tools">

			<!-- SHARE -->
			<!-- <span>
				<a href="https://www.addthis.com/bookmark.php" style="text-decoration:none;" onmouseover="return addthis_open(this, '', 'https://www.americanthinker.com/blog/2020/10/its_a_duty_for_patriots_to_own_a_firearm.html', 'The+Second+Amendment+states%3A+%26quot%3BA+well+regulated+Militia+being+necessary+to+the+security+of+a+free+State%2C+the+right+of+the+people+to+keep+and+bear+Arms%2C+shall+not+be+infringed.%26quot%3B%26nbsp%3B%26nbsp%3BThis+was+true+when+the+Bill+of+Rights+was+written%2C+an...');" onmouseout="addthis_close();" onclick="return addthis_sendto();"><img class="icon" src="https://s7.addthis.com/static/btn/sm-plus.gif" height="14" border="0" alt="Share" /> Share</a>			</span> -->

			<!-- <span class="separator">|</span> -->

			<!-- TWEET BUTTON -->
			<!-- <span class="addthis_toolbox addthis_default_style">
				<a class="addthis_button_twitter">&nbsp;Twitter</a>
			</span> -->

			<!-- <span class="separator">|</span> -->
			
			<!-- FACEBOOK SHARE -->
			<!-- <span class="addthis_toolbox addthis_default_style">
				<a class="addthis_button_facebook">&nbsp;Facebook</a>
			</span> -->

			<div class="addthis_native_toolbox"></div> 

						<!-- COMMENTS DISQUS -->
			 
			<span class="separator">|</span>
			<span>
				<img class="icon" src="/assets/images/comments.png" height="16" /> <a href="/blog/2020/10/its_a_duty_for_patriots_to_own_a_firearm_comments.html#comments-container" ><span class="vuukle-count" data="vuukle-count" data-empty-text="Add a"></span> Comments</a>
			</span>
			
			<!-- COMMENTS SPOT.IM -->
						<!-- <script type="text/javascript"
				src="//www.spot.im/embed/modules/launcher/bundle.js?module=messages-count"
				data-spot-id="150993">
			</script>
			<span>
				<img class="icon" src="/assets/images/comments.png" height="16" /> <a href="/blog/2020/10/its_a_duty_for_patriots_to_own_a_firearm_comments.html#comments-container"><div style="display:inline;" class="spot-im-replies-count" data-post-id="150993"></div> Comments</a>
			</span> -->

			<span class="separator print">|</span>

			<!-- PRINT -->
			<span class="print">
				<a href="javascript:void(0);" onclick="print();"><img src="/assets/images/icon-print.png"  /> Print</a>
			</span>

			<span class="separator email">|</span>
			
			<!-- EMAIL -->
			<!-- <span class="addthis_toolbox addthis_default_style email">
				<a class="addthis_button_email"> &nbsp;Email</a>
			</span> -->

			<div class="addthis_inline_share_toolbox_lazg"></div> 

		</div>                <!-- startprint -->
		<div class="article_date">October 11, 2020</div>

		<h1>It's a duty for patriots to own a firearm</h1>

		<div class="author">By <a href="/author/peter_skurkiss/">Peter Skurkiss</a></div>



            <!-- legacy mobile -->
            <div class="article_body top mrf-hidden"><p><p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">The Second Amendment states: &quot;A well regulated Militia being necessary to the security of a free State, the right of the people to keep and bear Arms, shall not be infringed.&quot;&nbsp;&nbsp;This was true when the Bill of Rights was written, and it is still valid today.&nbsp;&nbsp;However, in light of the&nbsp;left-wing-generated storm clouds over America, conservatives need an extended understanding of the 2nd Amendment.&nbsp;&nbsp;Not only do we, the people, have a right to possess firearms, but it has become practically a duty for able-bodied patriots to do so.&nbsp;</span></span></p>


                            <script type="text/javascript">
                                if(page_width_onload <= 479) {
                                    document.write('<div class="article_box_ad" id="div-gpt-ad-1345489840937-3"></div>');
                                    googletag.cmd.push(function () {
                                        googletag.display('div-gpt-ad-1345489840937-3');
                                    });
                                }
                            </script><p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">Does that sound extreme?&nbsp;&nbsp;In years past, it would be.&nbsp;&nbsp;But not today.&nbsp;&nbsp;The Democrats and their accomplices on the left are bound and possessed to turn America into something it never was intended to be and to do it without the true consent of the people.&nbsp;&nbsp;They are attempting this by a blatant coup from inside.&nbsp;&nbsp;Just look at the outrages done to&nbsp;overturn&nbsp;the last presidential election and to remove Donald Trump from office.&nbsp;&nbsp;And despite Trump having the power of the presidency and trying to get justice, none of the plotters has been brought to justice.&nbsp;&nbsp;None likely will, either &mdash;&nbsp;certainly&nbsp;not the big fish.&nbsp;&nbsp;The protection these traitors to the Constitution get from those in the&nbsp;Deep State bureaucracy and judicial system has been too strong to break.&nbsp;</span></span></p>

<p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">One of the fundamental reasons why Trump has become the target of a coup is that in the past, a coup wasn&#39;t necessary.&nbsp;&nbsp;The&nbsp;uniparty&nbsp;in conjunction with the corporate media gave&nbsp;America&nbsp;the&nbsp;choice&nbsp;between Tweedle Dee and&nbsp;Tweedle&nbsp;Dum.&nbsp;&nbsp;Perhaps now, in retrospect, this can be seen more clearly.&nbsp;&nbsp;Think of the Republican candidates&nbsp;since Ronald Reagan.&nbsp;&nbsp;There were George&nbsp;H. and George&nbsp;W.&nbsp;Bush, Bob Dole, John&nbsp;McCain, and Mitt&nbsp;Romney.&nbsp;&nbsp;All proclaimed to be conservatives, but all were in fact&nbsp;globalists&nbsp;and members of the establishment.&nbsp;&nbsp;None would ever think of launching America-first policies.&nbsp;&nbsp;None would have upset Washington&#39;s applecart.</span></span></p>

<p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">Trump somehow broke through.&nbsp;&nbsp;He&nbsp;was not Tweedle Dee or&nbsp;Tweedle&nbsp;Dum.&nbsp;&nbsp;Trump was more of 21st-century version of Pat Buchanan or Ross&nbsp;Perot.&nbsp;&nbsp;This panicked the&nbsp;uniparty&nbsp;and Deep State and triggered them into more overt actions.&nbsp;&nbsp;Their weapons of choice are a lying tongue and their high positions in government.&nbsp;</span></span></p>


                            <script type="text/javascript">
                                if(page_width_onload <= 479) {
                                    document.write('<div class="article_box_ad" id="div-gpt-ad-1567099776462-0" style="width: 300px; height: 600px;"></div>');
                                    googletag.cmd.push(function () {                                    
                                        googletag.display('div-gpt-ad-1567099776462-0');
                                    });
                                }
                            </script><p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">Is voting the answer?&nbsp;&nbsp;One hopes so.&nbsp;&nbsp;But the Democrats have a long history of cheating in elections.&nbsp;&nbsp;And what has ever been done about it?&nbsp;&nbsp;Little to nothing.&nbsp;&nbsp;As is often the case, the media cover up or downplay Democrat cheating.&nbsp;&nbsp;In this way, the public was never enlightened to what was going on.</span></span></p>

<p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">As bad as Democratic cheating was in the past, it is going to be epic this November.&nbsp;&nbsp;Now the cheating is preplanned (mail-in voting, etc.) and organized on a massive scale.&nbsp;&nbsp;An army of Democrat lawyers have even been recruited to make it harder than ever to expose cheating.&nbsp;&nbsp;They will throw dust in the air and obscure the cheating.&nbsp;&nbsp;Nothing is off the table in the Democrats&#39; crusade to get rid of Trump.</span></span></p>

<p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">Finally, there&#39;s the matter of the&nbsp;violence of&nbsp;&nbsp;Antifa and Black Lives Matter.&nbsp;&nbsp;This is a rebellion against the social order.&nbsp;&nbsp;But what is worse than the criminality of these groups is that Democrat mayors, governors, and presidential candidates turn a blind eye or are making excuses for it.&nbsp;&nbsp;If silence is consent, then the Democrat Party is fully on board and complicit with the lawlessness.&nbsp;&nbsp;&nbsp;</span></span></p>


                            <script type="text/javascript">
                                if(page_width_onload <= 479) {
                                    document.write('<div class="article_box_ad" id="div-gpt-ad-1567099718955-0"></div>');
                                    googletag.cmd.push(function () {                                    
                                        googletag.display('div-gpt-ad-1567099718955-0');
                                    });
                                }
                            </script><p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">If you live along the coast and the sky looks ominous, you know a hurricane is coming, and you make preparations.&nbsp;&nbsp;Dark clouds are over America, saying a&nbsp;storm&nbsp;is brewing.&nbsp;&nbsp;In this environment, the patriot has several duties.&nbsp;&nbsp;Two are to vote and to speak out.&nbsp;&nbsp;The third is to own a firearm.&nbsp;&nbsp;This is not just a right.&nbsp;&nbsp;It&#39;s now a duty.&nbsp;&nbsp;The gun never has to be used.&nbsp;&nbsp;Just possessing it, however, is a critical vote for freedom and the&nbsp;survival&nbsp;of our republic.&nbsp;</span></span></p></div>
            <!-- end legacy mobile -->

            <!-- desktop -->
                                
                    <script type="text/javascript">
                        if(page_width_onload > 479) { 
                            document.write('<div class=\'article_box_ad\' id=\'div-gpt-ad-1455834208841-0\'></div>');
                            googletag.cmd.push(function() { googletag.display('div-gpt-ad-1455834208841-0'); }); 
                        }
                    </script>                            
                
                <div class="article_body"><p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">The Second Amendment states: &quot;A well regulated Militia being necessary to the security of a free State, the right of the people to keep and bear Arms, shall not be infringed.&quot;&nbsp;&nbsp;This was true when the Bill of Rights was written, and it is still valid today.&nbsp;&nbsp;However, in light of the&nbsp;left-wing-generated storm clouds over America, conservatives need an extended understanding of the 2nd Amendment.&nbsp;&nbsp;Not only do we, the people, have a right to possess firearms, but it has become practically a duty for able-bodied patriots to do so.&nbsp;</span></span></p>

<p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">Does that sound extreme?&nbsp;&nbsp;In years past, it would be.&nbsp;&nbsp;But not today.&nbsp;&nbsp;The Democrats and their accomplices on the left are bound and possessed to turn America into something it never was intended to be and to do it without the true consent of the people.&nbsp;&nbsp;They are attempting this by a blatant coup from inside.&nbsp;&nbsp;Just look at the outrages done to&nbsp;overturn&nbsp;the last presidential election and to remove Donald Trump from office.&nbsp;&nbsp;And despite Trump having the power of the presidency and trying to get justice, none of the plotters has been brought to justice.&nbsp;&nbsp;None likely will, either &mdash;&nbsp;certainly&nbsp;not the big fish.&nbsp;&nbsp;The protection these traitors to the Constitution get from those in the&nbsp;Deep State bureaucracy and judicial system has been too strong to break.&nbsp;</span></span></p>

<p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">One of the fundamental reasons why Trump has become the target of a coup is that in the past, a coup wasn&#39;t necessary.&nbsp;&nbsp;The&nbsp;uniparty&nbsp;in conjunction with the corporate media gave&nbsp;America&nbsp;the&nbsp;choice&nbsp;between Tweedle Dee and&nbsp;Tweedle&nbsp;Dum.&nbsp;&nbsp;Perhaps now, in retrospect, this can be seen more clearly.&nbsp;&nbsp;Think of the Republican candidates&nbsp;since Ronald Reagan.&nbsp;&nbsp;There were George&nbsp;H. and George&nbsp;W.&nbsp;Bush, Bob Dole, John&nbsp;McCain, and Mitt&nbsp;Romney.&nbsp;&nbsp;All proclaimed to be conservatives, but all were in fact&nbsp;globalists&nbsp;and members of the establishment.&nbsp;&nbsp;None would ever think of launching America-first policies.&nbsp;&nbsp;None would have upset Washington&#39;s applecart.</span></span></p>

<p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">Trump somehow broke through.&nbsp;&nbsp;He&nbsp;was not Tweedle Dee or&nbsp;Tweedle&nbsp;Dum.&nbsp;&nbsp;Trump was more of 21st-century version of Pat Buchanan or Ross&nbsp;Perot.&nbsp;&nbsp;This panicked the&nbsp;uniparty&nbsp;and Deep State and triggered them into more overt actions.&nbsp;&nbsp;Their weapons of choice are a lying tongue and their high positions in government.&nbsp;</span></span></p>

<p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">Is voting the answer?&nbsp;&nbsp;One hopes so.&nbsp;&nbsp;But the Democrats have a long history of cheating in elections.&nbsp;&nbsp;And what has ever been done about it?&nbsp;&nbsp;Little to nothing.&nbsp;&nbsp;As is often the case, the media cover up or downplay Democrat cheating.&nbsp;&nbsp;In this way, the public was never enlightened to what was going on.</span></span></p>

<p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">As bad as Democratic cheating was in the past, it is going to be epic this November.&nbsp;&nbsp;Now the cheating is preplanned (mail-in voting, etc.) and organized on a massive scale.&nbsp;&nbsp;An army of Democrat lawyers have even been recruited to make it harder than ever to expose cheating.&nbsp;&nbsp;They will throw dust in the air and obscure the cheating.&nbsp;&nbsp;Nothing is off the table in the Democrats&#39; crusade to get rid of Trump.</span></span></p>

<p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">Finally, there&#39;s the matter of the&nbsp;violence of&nbsp;&nbsp;Antifa and Black Lives Matter.&nbsp;&nbsp;This is a rebellion against the social order.&nbsp;&nbsp;But what is worse than the criminality of these groups is that Democrat mayors, governors, and presidential candidates turn a blind eye or are making excuses for it.&nbsp;&nbsp;If silence is consent, then the Democrat Party is fully on board and complicit with the lawlessness.&nbsp;&nbsp;&nbsp;</span></span></p>

<p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">If you live along the coast and the sky looks ominous, you know a hurricane is coming, and you make preparations.&nbsp;&nbsp;Dark clouds are over America, saying a&nbsp;storm&nbsp;is brewing.&nbsp;&nbsp;In this environment, the patriot has several duties.&nbsp;&nbsp;Two are to vote and to speak out.&nbsp;&nbsp;The third is to own a firearm.&nbsp;&nbsp;This is not just a right.&nbsp;&nbsp;It&#39;s now a duty.&nbsp;&nbsp;The gun never has to be used.&nbsp;&nbsp;Just possessing it, however, is a critical vote for freedom and the&nbsp;survival&nbsp;of our republic.&nbsp;</span></span></p></div>
            <!-- end desktop -->		
        


        <!-- stopprint -->
		
		<!-- Donate Buttons Widget -->
        <div class="publir_8ca493ba7d21f999f80a1e9b4eca80ff">
            <div class="donate publir-donate-wvo" id="publirDonate_8ca493ba7d21f999f80a1e9b4eca80ff" >
                <script type="text/javascript" src="//a.publir.com/fundraisers/8ca493ba7d21f999f80a1e9b4eca80ff.js"
                ></script>
            </div>
        </div>


                                <script type='text/javascript'>
                        if(page_width_onload <= 479) {
                            document.write("<div id=\'div-gpt-ad-1345489840937-4\' style=\'text-align:center;\'></div>");
                            googletag.cmd.push(function() { googletag.display('div-gpt-ad-1345489840937-4'); });
                        }
                    </script>
            		                
				<div class="social_tools">

			<!-- SHARE -->
			<!-- <span>
				<a href="https://www.addthis.com/bookmark.php" style="text-decoration:none;" onmouseover="return addthis_open(this, '', 'https://www.americanthinker.com/blog/2020/10/its_a_duty_for_patriots_to_own_a_firearm.html', 'The+Second+Amendment+states%3A+%26quot%3BA+well+regulated+Militia+being+necessary+to+the+security+of+a+free+State%2C+the+right+of+the+people+to+keep+and+bear+Arms%2C+shall+not+be+infringed.%26quot%3B%26nbsp%3B%26nbsp%3BThis+was+true+when+the+Bill+of+Rights+was+written%2C+an...');" onmouseout="addthis_close();" onclick="return addthis_sendto();"><img class="icon" src="https://s7.addthis.com/static/btn/sm-plus.gif" height="14" border="0" alt="Share" /> Share</a>			</span> -->

			<!-- <span class="separator">|</span> -->

			<!-- TWEET BUTTON -->
			<!-- <span class="addthis_toolbox addthis_default_style">
				<a class="addthis_button_twitter">&nbsp;Twitter</a>
			</span> -->

			<!-- <span class="separator">|</span> -->
			
			<!-- FACEBOOK SHARE -->
			<!-- <span class="addthis_toolbox addthis_default_style">
				<a class="addthis_button_facebook">&nbsp;Facebook</a>
			</span> -->

			<div class="addthis_native_toolbox"></div> 

						<!-- COMMENTS DISQUS -->
			 
			<span class="separator">|</span>
			<span>
				<img class="icon" src="/assets/images/comments.png" height="16" /> <a href="/blog/2020/10/its_a_duty_for_patriots_to_own_a_firearm_comments.html#comments-container" ><span class="vuukle-count" data="vuukle-count" data-empty-text="Add a"></span> Comments</a>
			</span>
			
			<!-- COMMENTS SPOT.IM -->
						<!-- <script type="text/javascript"
				src="//www.spot.im/embed/modules/launcher/bundle.js?module=messages-count"
				data-spot-id="150993">
			</script>
			<span>
				<img class="icon" src="/assets/images/comments.png" height="16" /> <a href="/blog/2020/10/its_a_duty_for_patriots_to_own_a_firearm_comments.html#comments-container"><div style="display:inline;" class="spot-im-replies-count" data-post-id="150993"></div> Comments</a>
			</span> -->

			<span class="separator print">|</span>

			<!-- PRINT -->
			<span class="print">
				<a href="javascript:void(0);" onclick="print();"><img src="/assets/images/icon-print.png"  /> Print</a>
			</span>

			<span class="separator email">|</span>
			
			<!-- EMAIL -->
			<!-- <span class="addthis_toolbox addthis_default_style email">
				<a class="addthis_button_email"> &nbsp;Email</a>
			</span> -->

			<div class="addthis_inline_share_toolbox_lazg"></div> 

		</div>
		
				<div id="related-footer"></div>
        
		<div id='vuukle-comments'></div>

		<script>
                    var login_from_vuukle = function() {

                        if(typeof loginModal !== 'undefined') {
                            loginModal.loadModal("sign-in-up");
                        }
                    }
                    var VUUKLE_CONFIG = {
                        apiKey: "55971aa3-e05a-49d3-b2e9-83243ce15cc4",
                        //articleId: "300150993",
                        articleId: "150993",
                        img: "https://www.americanthinker.com/images/bucket/2020-10/224384_5_.jpg",                        /*tags: "Up to 3 tags separated by comma",// Not avilable in AT yet */
                        link: 'https://www.[url]',
                        url: 'https://www.americanthinker.com/blog/2020/10/its_a_duty_for_patriots_to_own_a_firearm_comments.html',
                        ads: {
                        	enabled: false
                        },
                        comments: {
                            maxChars: 20000,
                            enabled: false,
                            toxicityLimit: '0', // disabled
                            auth: {
                                facebook: false,
                                google: false,
                                twitter: false,
                                disqus: false,
                                password: false,
                                vuukle: false,
                                sso: {
                                    onClick: login_from_vuukle
                                }
                            },
                        }
                    };
                    // DON'T EDIT BELOW THIS LINE
                    (function() {
                        var d = document,
                            s = d.createElement('script');
                        s.src = 'https://cdn.vuukle.com/platform.js';
                        s.onload = function() {

                            if(typeof window.vuukleSSO == 'function') {
                                window.vuukleSSO();
                            } else {
                                window.vuukleFirst = true;
                            }
                        };
                        (d.head || d.body).appendChild(s);
                    })();
                </script>

	</div>

	<div class="column_364">

    <div class="double_top">
        <div class="follow_us">

    <h3>FOLLOW US ON</h3>

    <div class="social_buttons">
        <a href="https://www.facebook.com/pages/American-Thinker/144317282271701"><img
                    src="/assets/images/ICON-FACEBOOK.gif" alt="American Thinker on Facebook"/></a><a
                href="https://twitter.com/americanthinker"><img src="/assets/images/ICON-TWITTER.gif"
                                                                   alt="American Thinker on Twitter"/></a><a
                class="newsletter"
                href="javascript:void window.open('https://www.americanthinker.com/static/newsletter.html','','width=400,height=400,scrollbars=yes');"><img
                    src="/assets/images/at-newsletter-signup-graphic.gif" alt="American Thinker Newsletter Signup"/></a>
    </div>

</div>        
        <!--<div id="ora_container"></div>-->
    </div>

		<div class="side_links">

			<script type="text/javascript" src="/assets/js/widgets/recent_articles.js"></script>
			<script type="text/javascript" src="/assets/js/widgets/recent_blog_posts.js"></script>
			<script type="text/javascript" src="/assets/js/widgets/monthly_blog_archives.js"></script>
			
			<script src="/asset/top/rcmg_users_v2/rcmg_common.js" type="text/javascript"></script>
			<script src="/asset/top/rcmg_users_v2/rcmg_vuukle.js" type="text/javascript"></script>
			<script src="/asset/top/rcmg_users_v2/rcmg_modal.js" type="text/javascript"></script>
			<script src="/asset/top/rcmg_users_v2/rcmg_auth.js" type="text/javascript"></script>


		</div>

				<div class="side_ads">
			<!-- AT_160_600 -->
			<div id='div-gpt-ad-1345489840937-0' style='width:160px; height:600px; margin-top: 10px;'>
				<script type='text/javascript'>
					if(page_width_onload >= 640) {
						googletag.cmd.push(function() { googletag.display('div-gpt-ad-1345489840937-0'); });
					}
				</script>
			</div>
						
			<div id='div-gpt-ad-1455834208841-3' style='margin-top:10px; height:600px; width:160px;'>
				<script type="text/javascript">
					if(page_width_onload >= 640) {
						googletag.cmd.push(function() { googletag.display('div-gpt-ad-1455834208841-3'); });
					}
				</script>				
			</div>
            		</div>
		<div id="related-sidebar">

			<div class="bottom_ad" style="width:300px; margin:5px auto 0 auto;">
				
					<script type='text/javascript'>
						if( page_width_onload >= 768 ) { 
							document.write("<div id='div-gpt-ad-1345489840937-4'></div>");
							googletag.cmd.push(function() { googletag.display('div-gpt-ad-1345489840937-4'); });
						}
					</script>
				
			</div>


		</div>

        <script>
            if(publir_show_ads){
                document.write(' <div id="vuukle_sidebar_ad"></div>');
            }
        </script>

	</div>

</main>

    <script>
        if($('body').hasClass('no-comments')){
            $article_id =  VUUKLE_CONFIG.articleId; //blog posts do not have a prefix
            var url = 'https://api.vuukle.com/api/v1/Comments/getCommentCountListByHost?host=americanthinker.com&articleIds='+ $article_id;

            $.getJSON(url, function(resp){
                $('.vuukle-count').html(resp.data[$article_id]);
            });
        }

    </script>


		<footer role="contentinfo">

			<span class="links">
				<a href="/static/about_us.html">About Us</a> | 
				<a href="/static/contact_information.html">Contact</a> | 
				<a href="/static/privacy_policy.html">Privacy Policy</a> | 
				<a href="/static/rss_syndication.html">RSS Syndication</a>
			</span>

			<span class="copyright">&copy; American Thinker 2020</span>

			<div class="bottom_banner_ad">
				<div id='div-gpt-ad-1345489840937-6' style='width:728px; height:90px; margin: 10px auto 0;'>
					<script type='text/javascript'>
						if(page_width_onload >= 768) {
							googletag.cmd.push(function() { googletag.display('div-gpt-ad-1345489840937-6'); });
						}
					</script>
				</div>
			</div>

		</footer>

		<!-- AT_1_by_1_welcome -->
			<div id='div-gpt-ad-1345489840937-2' style='width:1px; height:1px;'>
				<script type='text/javascript'>
					googletag.cmd.push(function() { googletag.display('div-gpt-ad-1345489840937-2'); });
				</script>
			</div>
		<!-- END AT_1_by_1_welcome -->

		<!-- Start Quantcast tag -->
			<script type="text/javascript">
				_qoptions={
					qacct:"p-9bKF-NgTuSFM6"
				};
			</script>
			<script type="text/javascript" src="//edge.quantserve.com/quant.js"></script>
			<noscript>
				<img src="//pixel.quantserve.com/pixel/p-9bKF-NgTuSFM6.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
			</noscript>
		<!-- End Quantcast tag -->

		<!-- Addthis -->
			<!--<script type="text/javascript" src="https://s7.addthis.com/js/250/addthis_widget.js#pubid=aramanujan"></script>-->
			<script type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=aramanujan"></script> 

			<!--<script>
				var addthis_share = { email_template: "new_template" }
			</script>-->

      <script src="/assets/js/bottom.js?v=1"></script>

        <script src="https://a.publir.com/platform/ads.js" type="text/javascript"></script>
        <script type="text/javascript">
            if (publir_show_ads) {
                if (document.getElementById('adblock1122112')) {
            } else {
                    var p_currentPage = window.location.href;
                    var p_siteId = "7";
                    var p_json_final = {p_currentPage, p_siteId};
                    var p_url_7 = 'https://l026e7vji8.execute-api.us-east-1.amazonaws.com/default/pAnalytics';
                    fetch(p_url_7, {
                        method: 'POST',
                        mode: 'no-cors',
                        body: JSON.stringify(p_json_final),
                        credentials: 'include',
                        headers: {'Content-Type': 'text/plain',}
                    });
                    document.write('<scri' + 'pt src="https://fkrkkmxsqeb5bj9r.s3.amazonaws.com/7.js" type="text/javascript"></scri' + 'pt>');
                }
            }
        </script>



	</div></body>

</html>