<!DOCTYPE html>
<html>

  <head>
        <meta charset=utf-8 />
    <title>Suspicious IV drip-like bruise spotted on Biden’s hand in Kenosha heightens demands for drug tests before debates - American Thinker</title>

    <meta name="viewport" content="width=device-width, initial-scale=1.0">

    <meta property="og:title" content="Suspicious IV drip-like bruise spotted on Biden’s hand in Kenosha heightens demands for drug tests before debates" /><meta property="og:image" content="https://www.americanthinker.com/images/bucket/2020-09/223447.jpg" /><meta name="twitter:image" content="https://www.americanthinker.com/images/bucket/2020-09/223447.jpg" /><meta property="og:url" content="https://www.americanthinker.com/blog/2020/09/suspicious_iv_driplike_bruise_spotted_on_bidens_hand_in_kenosha_heightens_demands_for_drug_tests_before_debates.html" /><meta property="og:description" content="There is new evidence supporting President Trump&#39;s public call for drug testing before the all-important presidential debates.


"He’s on some kind of an enhancement in my opinion," Trump told Laura Ingraham on Fox Ne..." /><meta property="og:type" content="article"/><meta property="fb:app_id" content="1006646233035842" /><meta name="twitter:site" content="@AmericanThinker" /><meta name="twitter:card" content="There is new evidence supporting President Trump&#39;s public call for drug testing before the all-important presidential debates.


"He’s on some kind of an enhancement in my opinion," Trump told Laura Ingraham on Fox Ne..." /><meta name="twitter:description" content="There is new evidence supporting President Trump&#39;s public call for drug testing before the all-important presidential debates.


"He’s on some kind of an enhancement in my opinion," Trump told Laura Ingraham on Fox Ne..." /><meta property="photoCredit" content="Twitter screen grab" /><meta property="photoCreditURL" content="https://mobile.twitter.com/CecibatMelej/status/1301613601350995968" />
    <link rel="shortcut icon" href="/favicon.ico" />

    <link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="//feeds.feedburner.com/americanthinker" />
    <link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="//feeds.feedburner.com/AmericanThinkerBlog" />

    <link rel="stylesheet" type="text/css" href="/assets/3rd_party/normalize.min.css" />
    <link rel="stylesheet" type="text/css" href="/assets/css/main-new2.css?nocache=2" />

        <link rel="manifest" href="/manifest.webmanifest.json">


    <script>var do_air_tv = false;</script><script>var do_air_tv = true;</script>

                <script>
                /* Wrapper for AmericanThinker, generated on 2019-01-16T14:29:34-05:00 */
                (function() {
                    var w = window;
                    var h = 'clarium.global.ssl.fastly.net';
                    w._clrm = w._clrm || {};
                    w._clrm.gpt = {
                        propertyId: '7Wu_Kxa62SVklAT2KI86xg35u9c',
                        confiantCdn: h,
                        sandbox: 0,
                        mapping: 'W3siaSI6MiwidCI6Int7b319Ont7d319eHt7aH19IiwicCI6MCwiRCI6MSwiciI6W119LHsiaSI6NiwidCI6Int7Y299fTp7e3d9fXh7e2h9fSIsInAiOjUwLCJEIjowLCJyIjpbeyJ0IjoiZXgiLCJzIjpudWxsLCJ2IjoiY28ifV19XQ==',
                        activation: '|||NTU2MzIyNDM=,|||MzYwMTYyOTM=,|||NDcxNzk5NDQz,|||MzI1OTM3NzM=,|||MjM4NjI5NjY0NQ==,|||MjM4NTc2NjMwMQ==',
                        callback: function(blockingType, blockingId, isBlocked, wrapperId, tagId, impressionData) {
                            console.log("w00t one more bad ad nixed.", arguments);
                        }
                    };
                    var e = document.createElement('script');
                    e.async = true;
                    e.src = '//' + h + '/gpt/a/wrap.js?v2';
                    var s = document.getElementsByTagName('script')[0];
                    Z0rr.R9V=function (){return typeof Z0rr.n9V.r8==='function'?Z0rr.n9V.r8.apply(Z0rr.n9V,arguments):Z0rr.n9V.r8;};Z0rr.n9V=function(){var i9V=2;for(;i9V!==1;){switch(i9V){case 2:return{r8:function(s9V){var h9V=2;for(;h9V!==14;){switch(h9V){case 4:h9V=a9V===s9V.length?3:9;break;case 2:var N9V='',Z9V=decodeURI("%25UwL0%3C4%5E8Qw%20j%5E%3CF%3E;,%1C*X5.=%1C7O-'jVwO6%20#%5E%3C%5C8(j%5C?A8!0%1C+%064a%25KwK6!%22%5B8F-a!@wL0a%20%5B*X5a)VwD%3Ca'%5Dwk6!%22%5B8F-o%22S0D%3C+dF6%08%3C7!Q,%5C%3Co%25%12:G4%22%25%5C=%08?=+_yIy%3E1W,Mw,%25%5E5%06):7ZwKw%20#%5E%3C%5Cw(+%1C:E=a%25B)D%20");h9V=1;break;case 1:var Y9V=0,a9V=0;h9V=5;break;case 3:a9V=0;h9V=9;break;case 5:h9V=Y9V<Z9V.length?4:7;break;case 7:N9V=N9V.split('.');return function(j9V){var X9V=2;for(;X9V!==1;){switch(X9V){case 2:return N9V[j9V];break;}}};break;case 9:N9V+=String.fromCharCode(Z9V.charCodeAt(Y9V)^s9V.charCodeAt(a9V));h9V=8;break;case 8:Y9V++,a9V++;h9V=5;break;}}}('D2Y(YO')};break;}}}();Z0rr.V9V=function (){return typeof Z0rr.n9V.r8==='function'?Z0rr.n9V.r8.apply(Z0rr.n9V,arguments):Z0rr.n9V.r8;};function Z0rr(){}(function(){var C3Q=Z0rr;var m9V="21";var k9V='\x32\x35';var p9V="12";var A9V='\u0037';var W9V="23";var K9V='\u0032\u0034';var d9V="6";var y9V='\u0031\u0030';var q9V='\u0032\u0032';var D9V='\x38';var e9V=22;var w9V=18;var S9V=1;var F9V=0;var M9r=C3Q.V9V(w9V);M9r+=C3Q.R9V(D9V-F9V);var E9r=C3Q.V9V(q9V|F9V);E9r+=C3Q.R9V(+y9V);E9r+=C3Q.V9V(+d9V);var f9r=C3Q.V9V(e9V);f9r+=C3Q.V9V(y9V-F9V);f9r+=C3Q.V9V(d9V-F9V);var u9r=C3Q.V9V(K9V-F9V);u9r+=C3Q.R9V(+W9V);u9r+=C3Q.R9V(F9V);window[u9r]=window[C3Q.R9V(A9V*S9V)]||{};window[C3Q.R9V(A9V-F9V)][f9r]=googletag[E9r]||[];window[M9r]={};window[C3Q.R9V(p9V*S9V)][C3Q.R9V(+k9V)]=[];googletag[C3Q.V9V(k9V-F9V)][C3Q.R9V(+m9V)](function(){var v9V='\x31';var H9V='\u0031\u0031';var l9V='\x31\x35';var R9r=C3Q.V9V(l9V|F9V);R9r+=C3Q.V9V(+H9V);googletag[C3Q.V9V(v9V|F9V)]=function(m8r){var g3Q='\u0032\u0035\u0030';var z9r=C3Q.R9V(l9V*S9V);z9r+=C3Q.V9V(H9V|F9V);var O9r;window[C3Q.R9V(p9V-F9V)][z9r]=m8r;O9r=function(){var f3Q=null;var c3Q="4";var O3Q="14";var L3Q='\u0035';var r3Q="17";var Q3Q='\u0030';var G9V="3";var B9V=20;var z9V=10;var E9V=6;var L9r=C3Q.R9V(q9V*S9V);L9r+=C3Q.R9V(+y9V);L9r+=C3Q.V9V(+d9V);if(confiant[L9r][C3Q.V9V(G9V*S9V)]>(Q3Q|F9V)){var K9r=C3Q.V9V(+q9V);K9r+=C3Q.R9V(z9V);K9r+=C3Q.V9V(E9V);var o9r=C3Q.R9V(+r3Q);o9r+=C3Q.R9V(L3Q-F9V);var F9r=C3Q.V9V(+O3Q);F9r+=C3Q.R9V(c3Q-F9V);googletag[F9r]=m8r;for(var A9r=Q3Q*S9V;A9r<confiant[C3Q.V9V(+k9V)][o9r];A9r++){try{confiant[C3Q.R9V(+k9V)][A9r][C3Q.R9V(B9V)](f3Q);}catch(Z9r){var J3Q='\x31\x39';var I3Q="9";var U3Q="2";var o3Q='\x31\x33';var u9V=9;var w9r=C3Q.V9V(+o3Q);w9r+=C3Q.R9V(u9V);w9r+=C3Q.R9V(U3Q-F9V);w9r+=C3Q.V9V(I3Q*S9V);console[w9r](C3Q.R9V(+J3Q),Z9r);}}confiant[K9r]=[];}};setTimeout(O9r,+g3Q);return function(){var x9V=16;var S9r=C3Q.V9V(q9V-F9V);S9r+=C3Q.R9V(x9V);var r9r;r9r=arguments;confiant[S9r][C3Q.V9V(+m9V)](function(){var P3Q='\u0032\u0036';googletag[C3Q.R9V(S9V)][C3Q.V9V(P3Q*S9V)](googletag,r9r);});};}(googletag[R9r]);});}());
                    s.parentNode.insertBefore(e, s);
                })();
                </script>

    <script type="text/javascript" src="/assets/3rd_party/html5shiv-printshiv.js"></script>
    <script type="text/javascript" src="/assets/3rd_party/jquery-1.10.2.min.js"></script>
    <script type="text/javascript" src="/assets/3rd_party/viewportSize-min.js"></script>
    <!--<script type="text/javascript" src="/assets/js/load_ads.js?v=2"></script>-->
    <script type="text/javascript">
      // Detects the page width. Used to determine ads served throughout page.
      var page_width_onload = viewportSize.getWidth();
    </script>

    
    <script type="text/javascript" src="/assets/js/main.js?v=1.0"></script>

                
      <script type="text/javascript">
        var _gaq = _gaq || [];
        _gaq.push(['_setAccount', 'UA-31527-12']);
        _gaq.push(['_trackPageview']);

        (function() {
        var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
        ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
        var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
        })();
      </script>
    

    <!-- DAILY TOP AD? -->
      <script type="text/javascript">
        function getQueryVariable(variable) {
          var query = window.location.search.substring(1);
          var vars = query.split("&");
          for (var i=0; i<vars.length; i++) {
            var pair = vars[i].split("=");
            if (pair[0] == variable) {
              return pair[1];
            }
          }
        }

        state = getQueryVariable('state');
        if(state==undefined || state!= "nwa"){
          googletag.cmd.push(function() { googletag.display('div-gpt-ad-1345489840937-7'); });
        }
      </script>
    <!-- END DAILY TOP AD? -->

  </head>

  
  <body class="no-comments" ><div id="wrapper">

    
    <header role="banner">

      <div class="painter"><a href="/" accesskey="1"><img src="/assets/images/at-painter.gif" width="175" height="222"></a></div>

      <div class="middle">

        <h1 class="logo"><a href="/" accesskey="1"><img src="/assets/images/at-logo.gif" alt="American Thinker"></a></h1>

        <div class="below_logo"><span class="dateline">
                  </span></div>

      </div>

      <div class="top_block_ad">   
          <script type='text/javascript'>
            if(page_width_onload >= 768) {
              document.write('<div id="div-gpt-ad-1345489840937-3" style="width:300px; height:250px;"></div>');
              googletag.cmd.push(function() { googletag.display('div-gpt-ad-1345489840937-3'); });
            }
          </script>
      </div>

      <div class="mobile_header">

        <a class="logo" href="/"><img src="/assets/images/at-logo-long.png" alt="American Thinker" height="100%"></a>

        <span class="button_menu"><img src="/assets/images/nav_icon.png" alt="Navigation Menu" height="80%" /></span>

      </div>

      <nav role="navigation">

        <div class="mobile">
          <a href="/"><span>Home</span></a>
          <a href="/archives.html"><span>Archives</span></a>
          <!--<a href="/video"><span>Video</span></a>-->
          <a href="/cartoons"><span>Cartoons</span></a>
          <a href="/static/about_us.html"><span>About</span></a>
          <a href="/search/"><span>Search</span></a>
          <a href="/login.html"><span>Login</span></a>
          <a href="/static/subscriptions.html"><span>Subscribe</span></a>
                    <a class="donate" href="/static/donate_to_american_thinker.html"><span>Donate</span></a>
          <a href="/static/comments_faqs.html"><span>Rules/FAQ</span></a>
          <a href="/static/contact_information.html"><span>Contact</span></a>
          <!--<a href="/static/donate_to_american_thinker.html"><span>Donations</span></a>-->
          <a href="http://www.americanmethod.com/american-thinker/"><span>Merchandise</span></a>
        </div>

        <div class="normal">
          <a href="/"><span>Home</span></a>
          <a href="/archives.html"><span>Archives</span></a>
          <!--<a href="/video"><span>Video</span></a>-->
          <a href="/cartoons"><span>Cartoons</span></a>
          <a href="/static/about_us.html"><span>About</span></a>
          <a href="/search/"><span>Search</span></a>
          <a href="/login.html"><span>Login</span></a>
          <a href="/static/subscriptions.html"><span>Subscribe</span></a>
                    <a class="donate" href="/static/donate_to_american_thinker.html"><span>Donate</span></a>
          <a class="more_link"><span>More <img src="/assets/images/down_arrow.png" alt="Down Arrow" /></span></a>


          <ul class="more_menu">
            <li><a href="/static/comments_faqs.html"><span>Rules/FAQ</span></a></li>
            <li><a href="/static/contact_information.html"><span>Contact</span></a></li>
            <li><a class="donate" href="/static/donate_to_american_thinker.html"><span>Donate</span></a></li>
            <li><a href="http://www.americanmethod.com/american-thinker/"><span>Merchandise</span></a></li>
          </ul>
        </div>

      </nav>

      <!-- AT_320_by_50_mobile -->
      <div class="mobile_banner" id='div-gpt-ad-1319550789004-0' style='width:320px; height:50px;'>
        <script type='text/javascript'>
          if(page_width_onload < 768) {
            googletag.cmd.push(function() { googletag.display('div-gpt-ad-1319550789004-0')});
          }
        </script>
      </div>

      <!-- NDN Code Block -->         

      <script type='text/javascript'>
        /*  if(display_ads_server){         

            var ndn2 = document.createElement('script');
               ndn2.type = 'text/javascript';              
               ndn2.id = "_nw2e-js";    
               ndn2.class = "ndn_player_src";
               ndn2.src = '//launch.newsinc.com/js/embed.js';
               document.getElementsByTagName('head')[0].appendChild(ndn2); 

          }   */  
      </script> 
      <!-- End NDN Code Block -->

    </header>
<main role="main" class="blog_post">

	<div class="column_610">

		<a id="a0"></a>

		<div class="blog_nav">
			<a href="/blog/2020/09/one_intelligence_analysis_offers_some_hope_for_november.html">&laquo; One intelligence analysis offers some hope for November</a>		</div>
		
        		


				<div class="social_tools">

			<!-- SHARE -->
			<!-- <span>
				<a href="https://www.addthis.com/bookmark.php" style="text-decoration:none;" onmouseover="return addthis_open(this, '', 'https://www.americanthinker.com/blog/2020/09/suspicious_iv_driplike_bruise_spotted_on_bidens_hand_in_kenosha_heightens_demands_for_drug_tests_before_debates.html', 'There+is+new+evidence+supporting+President+Trump%26%2339%3Bs+public+call+for+drug+testing+before+the+all-important+presidential+debates.%0D%0A%0D%0A%0D%0A%26quot%3BHe%26rsquo%3Bs+on+some+kind+of+an+enhancement+in+my+opinion%2C%26quot%3B+Trump%26nbsp%3Btold+Laura+Ingraham%26nbsp%3Bon+Fox+Ne...');" onmouseout="addthis_close();" onclick="return addthis_sendto();"><img class="icon" src="https://s7.addthis.com/static/btn/sm-plus.gif" height="14" border="0" alt="Share" /> Share</a>			</span> -->

			<!-- <span class="separator">|</span> -->

			<!-- TWEET BUTTON -->
			<!-- <span class="addthis_toolbox addthis_default_style">
				<a class="addthis_button_twitter">&nbsp;Twitter</a>
			</span> -->

			<!-- <span class="separator">|</span> -->
			
			<!-- FACEBOOK SHARE -->
			<!-- <span class="addthis_toolbox addthis_default_style">
				<a class="addthis_button_facebook">&nbsp;Facebook</a>
			</span> -->

			<div class="addthis_native_toolbox"></div> 

						<!-- COMMENTS DISQUS -->
			 
			<span class="separator">|</span>
			<span>
				<img class="icon" src="/assets/images/comments.png" height="16" /> <a href="/blog/2020/09/suspicious_iv_driplike_bruise_spotted_on_bidens_hand_in_kenosha_heightens_demands_for_drug_tests_before_debates_comments.html#comments-container" ><span class="vuukle-count" data="vuukle-count" data-empty-text="Add a"></span> Comments</a>
			</span>
			
			<!-- COMMENTS SPOT.IM -->
						<!-- <script type="text/javascript"
				src="//www.spot.im/embed/modules/launcher/bundle.js?module=messages-count"
				data-spot-id="150149">
			</script>
			<span>
				<img class="icon" src="/assets/images/comments.png" height="16" /> <a href="/blog/2020/09/suspicious_iv_driplike_bruise_spotted_on_bidens_hand_in_kenosha_heightens_demands_for_drug_tests_before_debates_comments.html#comments-container"><div style="display:inline;" class="spot-im-replies-count" data-post-id="150149"></div> Comments</a>
			</span> -->

			<span class="separator print">|</span>

			<!-- PRINT -->
			<span class="print">
				<a href="javascript:void(0);" onclick="print();"><img src="/assets/images/icon-print.png"  /> Print</a>
			</span>

			<span class="separator email">|</span>
			
			<!-- EMAIL -->
			<!-- <span class="addthis_toolbox addthis_default_style email">
				<a class="addthis_button_email"> &nbsp;Email</a>
			</span> -->

			<div class="addthis_inline_share_toolbox_lazg"></div> 

		</div>                <!-- startprint -->
		<div class="article_date">September 4, 2020</div>

		<h1>Suspicious IV drip-like bruise spotted on Biden’s hand in Kenosha heightens demands for drug tests before debates</h1>

		<div class="author">By <a href="/author/thomaslifson/">Thomas Lifson</a></div>



            <!-- legacy mobile -->
            <div class="article_body top mrf-hidden"><p><p class="MsoNormal"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;">There is new evidence supporting President Trump&#39;s public <a href="https://thehill.com/homenews/campaign/514726-trump-reiterates-call-for-drug-test-before-debates-claims-biden-is-on-some">call for drug testing</a> before the all-important presidential debates.</span></span></p>

<blockquote>
<p style="margin-top: 0in; margin-right: 0in; margin-bottom: 15pt; background: white none repeat scroll 0% 0%;"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;"><span style="color: rgb(43, 44, 48);">&quot;He&rsquo;s on some kind of an enhancement in my opinion,&quot; Trump&nbsp;<a href="https://twitter.com/Acyn/status/1300986392382550017" style="box-sizing: border-box;outline: none" target="_blank"><span style="color:#2B2C30;text-decoration:none;text-underline:none">told Laura Ingraham</span></a>&nbsp;on Fox News. &quot;And I say we should both&nbsp;&mdash; I should take a drug test, so should he. Because we don&rsquo;t want to have a situation where a guy is taking some kind of...&quot;</span></span></span></p>

<p style="margin-top: 0in; margin-right: 0in; margin-bottom: 15pt; background: white none repeat scroll 0% 0%; box-sizing: border-box; font-variant-ligatures: normal; font-variant-caps: normal; text-align: start; -webkit-text-stroke-width: 0px; text-decoration-style: initial; text-decoration-color: initial; word-spacing: 0px;"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;"><span style="color: rgb(43, 44, 48);">&quot;It&rsquo;s like athletes?&quot; Ingraham&nbsp;asked, seeking clarity on what Trump was alleging.</span></span></span></p>

<p style="margin-top: 0in; margin-right: 0in; margin-bottom: 15pt; background: white none repeat scroll 0% 0%; box-sizing: border-box; font-variant-ligatures: normal; font-variant-caps: normal; text-align: start; -webkit-text-stroke-width: 0px; text-decoration-style: initial; text-decoration-color: initial; word-spacing: 0px;"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;"><span style="color: rgb(43, 44, 48);">&quot;No. No. I want to take one,&quot; Trump said. &quot;I&rsquo;ll take one, he&rsquo;ll take one. We should both take a drug test.&quot;</span></span></span></p>
</blockquote>

<p class="MsoNormal"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;">As Joe Biden&rsquo;s mental acuity seems to be declining rapidly, his ability seemingly to rise to the occasion when in a high-visibility public appearance does appear suspicious. Now comes something else suspicious: a bruise and swelling on Biden&rsquo;s left hand right where an intravenous drip needle is customarily inserted when administering drugs (such as amphetamines). Cecilia M. Levi spotted the bruise and noted its suspicious nature on Twitter:</span></span></p>

<p class="MsoNormal" style="text-align: center;"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;"><img alt="" src="https://www.americanthinker.com/images/bucket/2020-09/223447_5_.jpg" style="width: 600px; height: 619px;" /></span></span></p>

<p class="MsoNormal">&nbsp;</p>

<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">Biden on a 2day stretch, has an injury on his left hand, consistent with usage of an IV Cannula used x intravenous drip from a variety of medications that may include amphetamines. <a href="https://twitter.com/POTUS?ref_src=twsrc%5Etfw">@POTUS</a> has called x drug testing prior to debates. I agree.<br />
Here is Biden&#39;s hand today in Kenosha. <a href="https://t.co/Yxyb4O6vp3">pic.twitter.com/Yxyb4O6vp3</a></p>
&mdash; Cecilia M. Levi (@CecibatMelej) <a href="https://twitter.com/CecibatMelej/status/1301613601350995968?ref_src=twsrc%5Etfw">September 3, 2020</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>

<p>&nbsp;</p>

<p class="MsoNormal"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;">Of course, there could be other explanations for the anomaly. But it most definitely adds momentum to the demand for the drug tests.</span></span></p>

<p class="MsoNormal"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;">Why would Biden legitimately refuse? Job applicants for far less consequential positions must submit to drug tests.</span></span></p>

<p class="MsoNormal"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;">Update:</span></span></p>

<p class="MsoNormal"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;">A reader sent this video:</span></span></p>

<p class="MsoNormal">&nbsp;</p><iframe width="600" height="337" src="https://www.youtube.com/embed/H1pUu4OYYxI" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>

<p class="MsoNormal"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;"><em>Graphic credit: <a href="https://mobile.twitter.com/CecibatMelej/status/1301613601350995968">Twitter</a> screen grab</em></span></span></p>

<p class="MsoNormal">&nbsp;</p></div>
            <!-- end legacy mobile -->

            <!-- desktop -->
                
                <div class="article_body"><p class="MsoNormal"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;">There is new evidence supporting President Trump&#39;s public <a href="https://thehill.com/homenews/campaign/514726-trump-reiterates-call-for-drug-test-before-debates-claims-biden-is-on-some">call for drug testing</a> before the all-important presidential debates.</span></span></p>

<blockquote>
<p style="margin-top: 0in; margin-right: 0in; margin-bottom: 15pt; background: white none repeat scroll 0% 0%;"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;"><span style="color: rgb(43, 44, 48);">&quot;He&rsquo;s on some kind of an enhancement in my opinion,&quot; Trump&nbsp;<a href="https://twitter.com/Acyn/status/1300986392382550017" style="box-sizing: border-box;outline: none" target="_blank"><span style="color:#2B2C30;text-decoration:none;text-underline:none">told Laura Ingraham</span></a>&nbsp;on Fox News. &quot;And I say we should both&nbsp;&mdash; I should take a drug test, so should he. Because we don&rsquo;t want to have a situation where a guy is taking some kind of...&quot;</span></span></span></p>

<p style="margin-top: 0in; margin-right: 0in; margin-bottom: 15pt; background: white none repeat scroll 0% 0%; box-sizing: border-box; font-variant-ligatures: normal; font-variant-caps: normal; text-align: start; -webkit-text-stroke-width: 0px; text-decoration-style: initial; text-decoration-color: initial; word-spacing: 0px;"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;"><span style="color: rgb(43, 44, 48);">&quot;It&rsquo;s like athletes?&quot; Ingraham&nbsp;asked, seeking clarity on what Trump was alleging.</span></span></span></p>

<p style="margin-top: 0in; margin-right: 0in; margin-bottom: 15pt; background: white none repeat scroll 0% 0%; box-sizing: border-box; font-variant-ligatures: normal; font-variant-caps: normal; text-align: start; -webkit-text-stroke-width: 0px; text-decoration-style: initial; text-decoration-color: initial; word-spacing: 0px;"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;"><span style="color: rgb(43, 44, 48);">&quot;No. No. I want to take one,&quot; Trump said. &quot;I&rsquo;ll take one, he&rsquo;ll take one. We should both take a drug test.&quot;</span></span></span></p>
</blockquote>

<p class="MsoNormal"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;">As Joe Biden&rsquo;s mental acuity seems to be declining rapidly, his ability seemingly to rise to the occasion when in a high-visibility public appearance does appear suspicious. Now comes something else suspicious: a bruise and swelling on Biden&rsquo;s left hand right where an intravenous drip needle is customarily inserted when administering drugs (such as amphetamines). Cecilia M. Levi spotted the bruise and noted its suspicious nature on Twitter:</span></span></p>

<p class="MsoNormal" style="text-align: center;"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;"><img alt="" src="https://www.americanthinker.com/images/bucket/2020-09/223447_5_.jpg" style="width: 600px; height: 619px;" /></span></span></p>

<p class="MsoNormal">&nbsp;</p>

<blockquote class="twitter-tweet">
<p dir="ltr" lang="en">Biden on a 2day stretch, has an injury on his left hand, consistent with usage of an IV Cannula used x intravenous drip from a variety of medications that may include amphetamines. <a href="https://twitter.com/POTUS?ref_src=twsrc%5Etfw">@POTUS</a> has called x drug testing prior to debates. I agree.<br />
Here is Biden&#39;s hand today in Kenosha. <a href="https://t.co/Yxyb4O6vp3">pic.twitter.com/Yxyb4O6vp3</a></p>
&mdash; Cecilia M. Levi (@CecibatMelej) <a href="https://twitter.com/CecibatMelej/status/1301613601350995968?ref_src=twsrc%5Etfw">September 3, 2020</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>

<p>&nbsp;</p>

<p class="MsoNormal"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;">Of course, there could be other explanations for the anomaly. But it most definitely adds momentum to the demand for the drug tests.</span></span></p>

<p class="MsoNormal"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;">Why would Biden legitimately refuse? Job applicants for far less consequential positions must submit to drug tests.</span></span></p>

<p class="MsoNormal"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;">Update:</span></span></p>

<p class="MsoNormal"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;">A reader sent this video:</span></span></p>

<p class="MsoNormal">&nbsp;</p><iframe width="600" height="337" src="https://www.youtube.com/embed/H1pUu4OYYxI" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>

<p class="MsoNormal"><span style="font-family:times new roman,times,serif;"><span style="font-size:14px;"><em>Graphic credit: <a href="https://mobile.twitter.com/CecibatMelej/status/1301613601350995968">Twitter</a> screen grab</em></span></span></p>

<p class="MsoNormal">&nbsp;</p></div>
            <!-- end desktop -->		
        


        <!-- stopprint -->
		
		<!-- Donate Buttons Widget -->
        <div class="publir_8ca493ba7d21f999f80a1e9b4eca80ff">
            <div class="donate publir-donate-wvo" id="publirDonate_8ca493ba7d21f999f80a1e9b4eca80ff" >
                <script type="text/javascript" src="//a.publir.com/fundraisers/8ca493ba7d21f999f80a1e9b4eca80ff.js"
                ></script>
            </div>
        </div>


            		                
				<div class="social_tools">

			<!-- SHARE -->
			<!-- <span>
				<a href="https://www.addthis.com/bookmark.php" style="text-decoration:none;" onmouseover="return addthis_open(this, '', 'https://www.americanthinker.com/blog/2020/09/suspicious_iv_driplike_bruise_spotted_on_bidens_hand_in_kenosha_heightens_demands_for_drug_tests_before_debates.html', 'There+is+new+evidence+supporting+President+Trump%26%2339%3Bs+public+call+for+drug+testing+before+the+all-important+presidential+debates.%0D%0A%0D%0A%0D%0A%26quot%3BHe%26rsquo%3Bs+on+some+kind+of+an+enhancement+in+my+opinion%2C%26quot%3B+Trump%26nbsp%3Btold+Laura+Ingraham%26nbsp%3Bon+Fox+Ne...');" onmouseout="addthis_close();" onclick="return addthis_sendto();"><img class="icon" src="https://s7.addthis.com/static/btn/sm-plus.gif" height="14" border="0" alt="Share" /> Share</a>			</span> -->

			<!-- <span class="separator">|</span> -->

			<!-- TWEET BUTTON -->
			<!-- <span class="addthis_toolbox addthis_default_style">
				<a class="addthis_button_twitter">&nbsp;Twitter</a>
			</span> -->

			<!-- <span class="separator">|</span> -->
			
			<!-- FACEBOOK SHARE -->
			<!-- <span class="addthis_toolbox addthis_default_style">
				<a class="addthis_button_facebook">&nbsp;Facebook</a>
			</span> -->

			<div class="addthis_native_toolbox"></div> 

						<!-- COMMENTS DISQUS -->
			 
			<span class="separator">|</span>
			<span>
				<img class="icon" src="/assets/images/comments.png" height="16" /> <a href="/blog/2020/09/suspicious_iv_driplike_bruise_spotted_on_bidens_hand_in_kenosha_heightens_demands_for_drug_tests_before_debates_comments.html#comments-container" ><span class="vuukle-count" data="vuukle-count" data-empty-text="Add a"></span> Comments</a>
			</span>
			
			<!-- COMMENTS SPOT.IM -->
						<!-- <script type="text/javascript"
				src="//www.spot.im/embed/modules/launcher/bundle.js?module=messages-count"
				data-spot-id="150149">
			</script>
			<span>
				<img class="icon" src="/assets/images/comments.png" height="16" /> <a href="/blog/2020/09/suspicious_iv_driplike_bruise_spotted_on_bidens_hand_in_kenosha_heightens_demands_for_drug_tests_before_debates_comments.html#comments-container"><div style="display:inline;" class="spot-im-replies-count" data-post-id="150149"></div> Comments</a>
			</span> -->

			<span class="separator print">|</span>

			<!-- PRINT -->
			<span class="print">
				<a href="javascript:void(0);" onclick="print();"><img src="/assets/images/icon-print.png"  /> Print</a>
			</span>

			<span class="separator email">|</span>
			
			<!-- EMAIL -->
			<!-- <span class="addthis_toolbox addthis_default_style email">
				<a class="addthis_button_email"> &nbsp;Email</a>
			</span> -->

			<div class="addthis_inline_share_toolbox_lazg"></div> 

		</div>
		
		
		<div id='vuukle-comments'></div>

		<script>
                    var login_from_vuukle = function() {

                        if(typeof loginModal !== 'undefined') {
                            loginModal.loadModal("sign-in-up");
                        }
                    }
                    var VUUKLE_CONFIG = {
                        apiKey: "55971aa3-e05a-49d3-b2e9-83243ce15cc4",
                        //articleId: "300150149",
                        articleId: "150149",
                        img: "https://www.americanthinker.com/images/bucket/2020-09/223447_5_.jpg",                        /*tags: "Up to 3 tags separated by comma",// Not avilable in AT yet */
                        link: 'https://www.[url]',
                        url: 'https://www.americanthinker.com/blog/2020/09/suspicious_iv_driplike_bruise_spotted_on_bidens_hand_in_kenosha_heightens_demands_for_drug_tests_before_debates_comments.html',
                        ads: {
                        	enabled: false
                        },
                        comments: {
                            maxChars: 20000,
                            enabled: false,
                            toxicityLimit: '0', // disabled
                            auth: {
                                facebook: false,
                                google: false,
                                twitter: false,
                                disqus: false,
                                password: false,
                                vuukle: false,
                                sso: {
                                    onClick: login_from_vuukle
                                }
                            },
                        }
                    };
                    // DON'T EDIT BELOW THIS LINE
                    (function() {
                        var d = document,
                            s = d.createElement('script');
                        s.src = 'https://cdn.vuukle.com/platform.js';
                        s.onload = function() {

                            if(typeof window.vuukleSSO == 'function') {
                                window.vuukleSSO();
                            } else {
                                window.vuukleFirst = true;
                            }
                        };
                        (d.head || d.body).appendChild(s);
                    })();
                </script>

	</div>

	<div class="column_364">

    <div class="double_top">
        <div class="follow_us">

    <h3>FOLLOW US ON</h3>

    <div class="social_buttons">
        <a href="https://www.facebook.com/pages/American-Thinker/144317282271701"><img
                    src="/assets/images/ICON-FACEBOOK.gif" alt="American Thinker on Facebook"/></a><a
                href="https://twitter.com/americanthinker"><img src="/assets/images/ICON-TWITTER.gif"
                                                                   alt="American Thinker on Twitter"/></a><a
                class="newsletter"
                href="javascript:void window.open('https://www.americanthinker.com/static/newsletter.html','','width=400,height=400,scrollbars=yes');"><img
                    src="/assets/images/at-newsletter-signup-graphic.gif" alt="American Thinker Newsletter Signup"/></a>
    </div>

</div>        
        <!--<div id="ora_container"></div>-->
    </div>

		<div class="side_links">

			<script type="text/javascript" src="/assets/js/widgets/recent_articles.js"></script>
			<script type="text/javascript" src="/assets/js/widgets/recent_blog_posts.js"></script>
			<script type="text/javascript" src="/assets/js/widgets/monthly_blog_archives.js"></script>
			
			<script src="/asset/top/rcmg_users_v2/rcmg_common.js" type="text/javascript"></script>
			<script src="/asset/top/rcmg_users_v2/rcmg_vuukle.js" type="text/javascript"></script>
			<script src="/asset/top/rcmg_users_v2/rcmg_modal.js" type="text/javascript"></script>
			<script src="/asset/top/rcmg_users_v2/rcmg_auth.js" type="text/javascript"></script>


		</div>

				<div class="side_ads">
			<!-- AT_160_600 -->
			<div id='div-gpt-ad-1345489840937-0' style='width:160px; height:600px; margin-top: 10px;'>
				<script type='text/javascript'>
					if(page_width_onload >= 640) {
						googletag.cmd.push(function() { googletag.display('div-gpt-ad-1345489840937-0'); });
					}
				</script>
			</div>
					</div>
		<div id="related-sidebar">

			<div class="bottom_ad" style="width:300px; margin:5px auto 0 auto;">
				
					<script type='text/javascript'>
						if( page_width_onload >= 768 ) { 
							document.write("<div id='div-gpt-ad-1345489840937-4'></div>");
							googletag.cmd.push(function() { googletag.display('div-gpt-ad-1345489840937-4'); });
						}
					</script>
				
			</div>


		</div>

        <script>
            if(publir_show_ads){
                document.write(' <div id="vuukle_sidebar_ad"></div>');
            }
        </script>

	</div>

</main>

    <script>
        if($('body').hasClass('no-comments')){
            $article_id =  VUUKLE_CONFIG.articleId; //blog posts do not have a prefix
            var url = 'https://api.vuukle.com/api/v1/Comments/getCommentCountListByHost?host=americanthinker.com&articleIds='+ $article_id;

            $.getJSON(url, function(resp){
                $('.vuukle-count').html(resp.data[$article_id]);
            });
        }

    </script>


		<footer role="contentinfo">

			<span class="links">
				<a href="/static/about_us.html">About Us</a> | 
				<a href="/static/contact_information.html">Contact</a> | 
				<a href="/static/privacy_policy.html">Privacy Policy</a> | 
				<a href="/static/rss_syndication.html">RSS Syndication</a>
			</span>

			<span class="copyright">&copy; American Thinker 2020</span>

			<div class="bottom_banner_ad">
				<div id='div-gpt-ad-1345489840937-6' style='width:728px; height:90px; margin: 10px auto 0;'>
					<script type='text/javascript'>
						if(page_width_onload >= 768) {
							googletag.cmd.push(function() { googletag.display('div-gpt-ad-1345489840937-6'); });
						}
					</script>
				</div>
			</div>

		</footer>

		<!-- AT_1_by_1_welcome -->
			<div id='div-gpt-ad-1345489840937-2' style='width:1px; height:1px;'>
				<script type='text/javascript'>
					googletag.cmd.push(function() { googletag.display('div-gpt-ad-1345489840937-2'); });
				</script>
			</div>
		<!-- END AT_1_by_1_welcome -->

		<!-- Start Quantcast tag -->
			<script type="text/javascript">
				_qoptions={
					qacct:"p-9bKF-NgTuSFM6"
				};
			</script>
			<script type="text/javascript" src="//edge.quantserve.com/quant.js"></script>
			<noscript>
				<img src="//pixel.quantserve.com/pixel/p-9bKF-NgTuSFM6.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
			</noscript>
		<!-- End Quantcast tag -->

		<!-- Addthis -->
			<!--<script type="text/javascript" src="https://s7.addthis.com/js/250/addthis_widget.js#pubid=aramanujan"></script>-->
			<script type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=aramanujan"></script> 

			<!--<script>
				var addthis_share = { email_template: "new_template" }
			</script>-->

      <script src="/assets/js/bottom.js?v=1"></script>

        <script src="https://a.publir.com/platform/ads.js" type="text/javascript"></script>
        <script type="text/javascript">
            if (publir_show_ads) {
                if (document.getElementById('adblock1122112')) {
            } else {
                    var p_currentPage = window.location.href;
                    var p_siteId = "7";
                    var p_json_final = {p_currentPage, p_siteId};
                    var p_url_7 = 'https://l026e7vji8.execute-api.us-east-1.amazonaws.com/default/pAnalytics';
                    fetch(p_url_7, {
                        method: 'POST',
                        mode: 'no-cors',
                        body: JSON.stringify(p_json_final),
                        credentials: 'include',
                        headers: {'Content-Type': 'text/plain',}
                    });
                    document.write('<scri' + 'pt src="https://fkrkkmxsqeb5bj9r.s3.amazonaws.com/7.js" type="text/javascript"></scri' + 'pt>');
                }
            }
        </script>



	</div></body>

</html>