<!DOCTYPE html>
<html>

	<head>

		<meta charset=utf-8 />
		<title>Articles: Why JFK Would Endorse President Trump’s Immigration Proposals</title>

		<meta name="viewport" content="width=device-width, initial-scale=1.0">

		<meta property="og:title" content="Articles: Why JFK Would Endorse President Trump’s Immigration Proposals" /><meta property="og:image" content="http://www.americanthinker.com/assets/images/at-painter-og-image.png" /><meta property="og:url" content="http://www.americanthinker.com/articles/2017/01/why_jfk_would_endorse_president_trumps_immigration_proposals.html" />
		<link rel="shortcut icon" href="/favicon.ico" />

		<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://feeds.feedburner.com/americanthinker" />
		<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://feeds.feedburner.com/AmericanThinkerBlog" />

		<link rel="stylesheet" type="text/css" href="/assets/3rd_party/normalize.min.css" />
		<link rel="stylesheet" type="text/css" href="/assets/css/main.css?nocache=1" />
		<script type="text/javascript" async src="http://launch.newsinc.com/js/embed.js" id="_nw2e-js"></script>

		
		<script type="text/javascript" src="/assets/3rd_party/html5shiv-printshiv.js"></script>
		<script type="text/javascript" src="/assets/3rd_party/jquery-1.10.2.min.js"></script>
		<script type="text/javascript" src="/assets/3rd_party/viewportSize-min.js"></script>
		<!--<script type="text/javascript" src="/assets/js/load_ads.js?v=2"></script>-->
		<script type="text/javascript">
			// Detects the page width. Used to determine ads served throughout page.
			var page_width_onload = viewportSize.getWidth();
		</script>

		
		<script type="text/javascript" src="/assets/js/main.js"></script>


		<!-- subscriber scripts -->
		<script type="text/javascript" src="//assets.publir.com/client/subscriber.js"></script>
        <script type="text/javascript">
            pubsubs.publisher_token = "e4da3b7fbbce2345d7772b0674a318d5";
            pubsubs.ad_callbacks = ['show_ads'];
            pubsubs.init();
           	function show_ads () {
           		$('head').append('<style>div[id^="sas"], div[class^="sas"], div[id^="ad"], div[class^="ad"] {display: block !important;}</style>'); 
            }
        </script>
        <style>
        	div[id^="sas"], div[class^="sas"], div[id^="ad"], div[class^="ad"] {display: none !important;} 
        </style>




		

			<script type="text/javascript"> 
				if(display_ads_server){
					var s=document.createElement('script');
					s.async="async";
					s.type="text/javascript";
					s.src='http://www.americanthinker.com/assets/js/load_ads.js?v=2';
					var h=document.getElementsByTagName('script')[0];
					h.parentNode.insertBefore(s,h);
				} 
			</script>

        	<!-- GOOGLE ADS -->
			<script type='text/javascript'>
				var googletag = googletag || {};
				googletag.cmd = googletag.cmd || [];
				(function() {
				var gads = document.createElement('script');
				gads.async = true;
				gads.type = 'text/javascript';
				var useSSL = 'https:' == document.location.protocol;
				//gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
				if(display_ads_server){gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';};
				var node = document.getElementsByTagName('script')[0];
				node.parentNode.insertBefore(gads, node);
				})();
			</script>

			<script type='text/javascript'>
					googletag.cmd.push(function() {
				
					googletag.defineSlot('/1004503/AT_160_600', [160, 600], 'div-gpt-ad-1345489840937-0').addService(googletag.pubads());
					//googletag.defineSlot('/1004503/AT_180_150', [180, 150], 'div-gpt-ad-1345489840937-1').addService(googletag.pubads());
					//googletag.defineSlot('/1004503/AT_1_by_1_welcome', [1, 1], 'div-gpt-ad-1345489840937-2').addService(googletag.pubads()); 
					googletag.defineSlot('/1004503/AT_300_250', [300, 250], 'div-gpt-ad-1345489840937-3').addService(googletag.pubads());
					googletag.defineSlot('/1004503/AT_300_250_bottom', [300, 250], 'div-gpt-ad-1345489840937-4').addService(googletag.pubads());
					googletag.defineSlot('/1004503/AT_468_60', [468, 60], 'div-gpt-ad-1345489840937-5').addService(googletag.pubads());
					googletag.defineSlot('/1004503/AT_728_90', [728, 90], 'div-gpt-ad-1345489840937-6').addService(googletag.pubads());
					//googletag.defineSlot('/1004503/AT_sponsored', [1, 1], 'div-gpt-ad-1345489840937-7').addService(googletag.pubads());
					//googletag.defineSlot('/1004503/AT_sponsored_video', [1, 1], 'div-gpt-ad-1345489840937-8').addService(googletag.pubads());
					googletag.defineSlot('/1004503/AT_320_by_50_mobile', [320, 50], 'div-gpt-ad-1319550789004-0').addService(googletag.pubads()); 

					googletag.defineSlot('/1004503/AT_610_by_60', [610, 60], 'div-gpt-ad-1455834208841-2').addService(googletag.pubads());	
					googletag.defineSlot('/1004503/AT_300_250_middle', [300, 250], 'div-gpt-ad-1455834208841-0').addService(googletag.pubads());		
					googletag.defineSlot('/1004503/AT_160_by_600_bottom', [160, 600], 'div-gpt-ad-1455834208841-3').addService(googletag.pubads());	

					googletag.defineSlot('/1004503/AT_365_by_100', [365, 100], 'div-gpt-ad-1457979917706-0').addService(googletag.pubads());	

					googletag.pubads().enableSingleRequest();
				    googletag.pubads().collapseEmptyDivs();

					googletag.enableServices();
				});
			</script>
            <!-- END GOOGLE ADS -->
			            
			<script type="text/javascript">
				var _gaq = _gaq || [];
				_gaq.push(['_setAccount', 'UA-31527-12']);
				_gaq.push(['_trackPageview']);

				(function() {
				var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
				ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
				var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
		

		<!-- DAILY TOP AD? -->
			<script type="text/javascript">
				function getQueryVariable(variable) {
					var query = window.location.search.substring(1);
					var vars = query.split("&");
					for (var i=0; i<vars.length; i++) {
						var pair = vars[i].split("=");
						if (pair[0] == variable) {
							return pair[1];
						}
					}
				}

				state = getQueryVariable('state');
				if(state==undefined || state!= "nwa"){
					googletag.cmd.push(function() { googletag.display('div-gpt-ad-1345489840937-7'); });
				}
			</script>
		<!-- END DAILY TOP AD? -->

	</head>

	<body><div id="wrapper">

		
		<header role="banner">

			<div class="painter"><a href="/" accesskey="1"><img src="/assets/images/at-painter.gif" width="175" height="222"></a></div>

			<div class="middle">

				<h1 class="logo"><a href="/" accesskey="1"><img src="/assets/images/at-logo.gif" alt="American Thinker"></a></h1>

				<div class="below_logo"><span class="dateline">
									</span></div>

			</div>

			<div class="top_block_ad">   
				<div id='div-gpt-ad-1345489840937-3' style='width:300px; height:250px;'>
					<script type='text/javascript'>
						if(page_width_onload >= 768) {
							googletag.cmd.push(function() { googletag.display('div-gpt-ad-1345489840937-3'); });
						}
					</script>
				</div>
			</div>

			<div class="mobile_header">

				<a class="logo" href="/"><img src="/assets/images/at-logo-long.png" alt="American Thinker" height="100%"></a>

				<span class="button_menu"><img src="/assets/images/nav_icon.png" alt="Navigation Menu" height="80%" /></span>

			</div>

			<nav role="navigation">

				<div class="mobile"><!--
					--><a href="/"><span>Home</span></a><!--
					--><a href="/archives.html"><span>Archives</span></a><!--
					--><a href="/video"><span>Video</span></a><!--
					--><a href="/cartoons"><span>Cartoons</span></a><!--
					--><a href="/static/about_us.html"><span>About</span></a><!--
					--><a href="/search/"><span>Search</span></a><!--
					--><a href="/login.html"><span>Login</span></a><!--
					--><a href="/static/comments_faqs.html"><span>Rules/FAQ</span></a><!--
					--><a href="/static/contact_information.html"><span>Contact</span></a><!--
					--><a href="/static/donate_to_american_thinker.html"><span>Donations</span></a><!--
					--><a href="http://www.americanmethod.com/american-thinker/"><span>Merchandise</span></a><!--
				--></div>

				<div class="normal">
					<a href="/"><span>Home</span></a>
					<a href="/archives.html"><span>Archives</span></a>
					<a href="/video"><span>Video</span></a>
					<a href="/cartoons"><span>Cartoons</span></a>
					<a href="/static/about_us.html"><span>About</span></a>
					<a href="/search/"><span>Search</span></a>
					<a href="/login.html"><span>Login</span></a>
					<a class="more_link"><span>More <img src="/assets/images/down_arrow.png" alt="Down Arrow" /></span></a>

					<ul class="more_menu">
						<li><a href="/static/comments_faqs.html"><span>Rules/FAQ</span></a></li>
						<li><a href="/static/contact_information.html"><span>Contact</span></a></li>
						<li><a href="/static/donate_to_american_thinker.html"><span>Donations</span></a></li>
						<li><a href="http://www.americanmethod.com/american-thinker/"><span>Merchandise</span></a></li>
					</ul>
				</div>

			</nav>

			<!-- AT_320_by_50_mobile -->
			<div class="mobile_banner" id='div-gpt-ad-1319550789004-0' style='width:320px; height:50px;'>
				<script type='text/javascript'>
					if(page_width_onload < 768) {
						googletag.cmd.push(function() { googletag.display('div-gpt-ad-1319550789004-0')});
					}
				</script>
			</div>

			<!-- NDN Code Block -->
			<!--<script type="text/javascript" src="http://assets.newsinc.com/ndn.2.js"></script>-->
			<script type="text/javascript" src="http://launch.newsinc.com/js/embed.js" id="_nw2e-js" class="ndn_player_src"></script>
			<!-- End NDN Code Block -->

		</header>
<main role="main" class="article">

	<div class="column_610">

		<a id="a0120495"></a>

		<div class="breadcrumbs">
			<ul>
				<li><a href="/archives.html">Archives Home &rarr;</a></li>
				<li>Articles</li>
			</ul>
		</div>

				<div class="top_article_ad" id="div-gpt-ad-1455834208841-2">	 		
			<script type="text/javascript">
				if(page_width_onload >= 640) {
					googletag.cmd.push(function() { googletag.display('div-gpt-ad-1455834208841-2'); });
				}				
			</script>			
		</div>
        
				<div class="social_tools">

			<!-- SHARE -->
			<span>
				<a href="http://www.addthis.com/bookmark.php" style="text-decoration:none;" onmouseover="return addthis_open(this, '', 'http://www.americanthinker.com/articles/2017/01/why_jfk_would_endorse_president_trumps_immigration_proposals.html', 'JFK+was+so+concerned+about+immigration+that+he+wrote+A+Nation+of+Immigrants+in+1958.+His+book+was+expanded+and+republished+posthumously+in+1964.+In+his+Presidential+Message+to+Congress+of+July+23%2C+1963%2C+JFK+recommended+replacement+of+the+%26ldquo%3Bnatio...');" onmouseout="addthis_close();" onclick="return addthis_sendto();"><img class="icon" src="http://s7.addthis.com/static/btn/sm-plus.gif" height="14" border="0" alt="Share" /> Share</a>			</span>

			<span class="separator">|</span>

			<!-- TWEET BUTTON -->
			<span class="addthis_toolbox addthis_default_style">
				<a class="addthis_button_twitter">&nbsp;Twitter</a>
			</span>

			<span class="separator">|</span>
			
			<!-- FACEBOOK SHARE -->
			<span class="addthis_toolbox addthis_default_style">
				<a class="addthis_button_facebook">&nbsp;Facebook</a>
			</span>

			<span class="separator">|</span>

			<!-- COMMENTS -->
			<span>
				<img class="icon" src="/assets/images/comments.png" height="16" /> <a href="/articles/2017/01/why_jfk_would_endorse_president_trumps_immigration_proposals_comments.html#disqus_thread" data-disqus-identifier="200120495"> Comments</a>
			</span>

			<span class="separator print">|</span>

			<!-- PRINT -->
			<span class="print">
				<a href="javascript:void(0);" onclick="print();"><img src="/assets/images/icon-print.png"  /> Print</a>
			</span>

			<span class="separator email">|</span>
			
			<!-- EMAIL -->
			<span class="addthis_toolbox addthis_default_style email">
				<a class="addthis_button_email"> &nbsp;Email</a>
			</span>

		</div>
                <!-- startprint -->
		<div class="article_date">January 21, 2017</div>

		<h1>Why JFK Would Endorse President Trump’s Immigration Proposals</h1>

		<div class="author">By <a href="/author/jay_tucker/">Jay Tucker</a></div>

		<div class="article_body top"><p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">JFK was so concerned about immigration that he wrote <a href="https://www.amazon.com/Nation-Immigrants-John-F-Kennedy/dp/0061447544"><em>A Nation of Immigrants</em></a> in 1958. His book was expanded and republished posthumously in 1964. In his Presidential Message to Congress of July 23, 1963, JFK recommended replacement of the &ldquo;national origins&rdquo; quota system, which replacement was later accomplished by law in 1965. However, he conditioned his immigration recommendations upon adoption of a formula which would take into account three factors in the following order of priority:</span></span></p>

<blockquote>
<p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">(1) the skills of the immigrant and their relationship to our need; (2) the family relationship between immigrants and persons already here, so that reuniting families is encouraged and (3) the priority of registration.</span></span></p></blockquote></div>

				<div class="article_box_ad" id="div-gpt-ad-1455834208841-0">
			<script type="text/javascript">
				googletag.cmd.push(function() { googletag.display('div-gpt-ad-1455834208841-0'); });
			</script>			 
		</div>
        
		<div class="article_body bottom"><blockquote>
</blockquote>

<p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">Trump&rsquo;s immigration proposals are set out on his <a href="https://www.donaldjtrump.com/policies/immigration/">campaign website</a>.&nbsp;JFK&rsquo;s first priority is consistent with Trump&rsquo;s proposal that immigrants must not displace American workers and must be skilled so as to avoid being a welfare burden. In regard to his second priority, JFK refers to such &ldquo;persons already here&rdquo; as &ldquo;United States citizens and lawfully resident aliens.&rdquo; This priority is consistent with Trump&rsquo;s lack of support for families of those who have chosen to enter the United States unlawfully. His third priority is consistent with Trump&rsquo;s expressed policy requirement that proposed immigrants &ldquo;<a href="http://www.cnn.com/2016/09/05/politics/donald-trump-immigration">get in line</a>.&rdquo;</span></span></p>

<p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">Admission of refugees into the United States has been the subject of special refugee legislation. A part of the Refugee Relief Act of 1953 (67 Stat. 400) provided for admission of a limited number of persons who were fleeing from communism in Communist or Communist controlled countries. (Note that most Muslims seeking to immigrate to the United States are not fleeing the ideology of Islam, but subscribe to Islamic ideology and intend to carry out its directives and to live by its tenets.) Immigration by Communists was outlawed by the Immigration and Nationality Act of 1952 (66 Stat. 163). However, the Refugee Relief Act of 1953 allowed immigration of a small number of refugees from non-Communist and non-Communist dominated countries and &ldquo;escapees&rdquo; from Communist and Communist-dominated or occupied areas of Europe. The conditions established in 1953 for admission of such aliens are equivalent to or exceed the conditions/restrictions proposed by Trump for immigration by refugees. The Refugee Relief Act of 1953 required in Section 7 that no visa would be issued to any alien under the Act unless an assurance had first been given by a citizen or citizens of the United States that such alien, if admitted to the United States , would be suitably employed without displacing some other person from employment and that such alien and the members of such alien&rsquo;s family who were to accompany such alien and who proposed to live with such alien would not become public charges and would have housing without displacing some other person from such housing and required that each such assurance was required to be the personal obligation of the citizen or citizens giving or submitting such assurance. Applicants were also required to undergo a thorough security screening. Applicants were also required to provide documentation that guaranteed readmission to the country in which the applicant obtained a visa. Proper vetting of applicants as proposed by Trump was also part of JFK&rsquo;s immigration proposal: &ldquo;Immigrants would still be given tests for health, intelligence, morality, and security.&rdquo; The conditions established by law at that time and proposed by JFK for admission of such aliens are consistent with the requirements and restrictions proposed by Trump for admission of refugees.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span></span></p>

<p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">JFK (and others, including Hubert Humphrey) co-sponsored a bill which led to the Communist Control Act of 1954 (68 Stat. 775) which outlawed the Communist Party. Many, including liberals, have asserted that the provisions and legal findings as to Communism in the Immigration and Nationality Act of 1952 and the Communist Control Act of 1954 should be applied to Islamic ideology and Islamic immigration. They generally rely on the provisions in those acts which find that organizations with the objective of control, takeover, or overthrow of the U.S. government by force or violence and organizations which acknowledge no constitutional statutory limitations upon its conduct or upon that of its members should be considered a clear and present danger. In <a href="http://www.enotes.com/major-acts-congress/communist-control-act/">a&nbsp;2009 article</a>, Carl Auerbach, a liberal and a former constitutional law professor and dean at the University of Minnesota Law School , wrote that Senator Humphrey &ldquo;believed that liberals should take the lead in fighting Communism as well as all other totalitarian creeds and movements.&rdquo; Auerbach stated further in that article: &ldquo;Many nations have laws outlawing totalitarian organizations. The United States may have to take a position on whether democratic principles give legitimacy to Muslim fundamentalist movements, such as those in Algeria and Pakistan, that seek political power by legal means only to crush democracy. The Communist Control Act is a precedent for not tolerating intolerant political movements.&rdquo;</span></span></p>

<p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">The decision to be made by Trump, and perhaps Congress, is the extent to which proposed immigrants will be allowed entry based on the priorities recommended by JFK and denied entry based upon their adherence to an ideology which is inconsistent with the principles of the Constitution and/or which poses an unacceptable security risk. Democrats who voted for President Trump will surely feel vindicated as he follows key provisions of the immigration pathway recommended by President Kennedy.&nbsp; &nbsp;&nbsp;</span></span></p></div>

		<div class="article_body"><p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">JFK was so concerned about immigration that he wrote <a href="https://www.amazon.com/Nation-Immigrants-John-F-Kennedy/dp/0061447544"><em>A Nation of Immigrants</em></a> in 1958. His book was expanded and republished posthumously in 1964. In his Presidential Message to Congress of July 23, 1963, JFK recommended replacement of the &ldquo;national origins&rdquo; quota system, which replacement was later accomplished by law in 1965. However, he conditioned his immigration recommendations upon adoption of a formula which would take into account three factors in the following order of priority:</span></span></p>

<blockquote>
<p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">(1) the skills of the immigrant and their relationship to our need; (2) the family relationship between immigrants and persons already here, so that reuniting families is encouraged and (3) the priority of registration.</span></span></p>
</blockquote>

<p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">Trump&rsquo;s immigration proposals are set out on his <a href="https://www.donaldjtrump.com/policies/immigration/">campaign website</a>.&nbsp;JFK&rsquo;s first priority is consistent with Trump&rsquo;s proposal that immigrants must not displace American workers and must be skilled so as to avoid being a welfare burden. In regard to his second priority, JFK refers to such &ldquo;persons already here&rdquo; as &ldquo;United States citizens and lawfully resident aliens.&rdquo; This priority is consistent with Trump&rsquo;s lack of support for families of those who have chosen to enter the United States unlawfully. His third priority is consistent with Trump&rsquo;s expressed policy requirement that proposed immigrants &ldquo;<a href="http://www.cnn.com/2016/09/05/politics/donald-trump-immigration">get in line</a>.&rdquo;</span></span></p>

<p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">Admission of refugees into the United States has been the subject of special refugee legislation. A part of the Refugee Relief Act of 1953 (67 Stat. 400) provided for admission of a limited number of persons who were fleeing from communism in Communist or Communist controlled countries. (Note that most Muslims seeking to immigrate to the United States are not fleeing the ideology of Islam, but subscribe to Islamic ideology and intend to carry out its directives and to live by its tenets.) Immigration by Communists was outlawed by the Immigration and Nationality Act of 1952 (66 Stat. 163). However, the Refugee Relief Act of 1953 allowed immigration of a small number of refugees from non-Communist and non-Communist dominated countries and &ldquo;escapees&rdquo; from Communist and Communist-dominated or occupied areas of Europe. The conditions established in 1953 for admission of such aliens are equivalent to or exceed the conditions/restrictions proposed by Trump for immigration by refugees. The Refugee Relief Act of 1953 required in Section 7 that no visa would be issued to any alien under the Act unless an assurance had first been given by a citizen or citizens of the United States that such alien, if admitted to the United States , would be suitably employed without displacing some other person from employment and that such alien and the members of such alien&rsquo;s family who were to accompany such alien and who proposed to live with such alien would not become public charges and would have housing without displacing some other person from such housing and required that each such assurance was required to be the personal obligation of the citizen or citizens giving or submitting such assurance. Applicants were also required to undergo a thorough security screening. Applicants were also required to provide documentation that guaranteed readmission to the country in which the applicant obtained a visa. Proper vetting of applicants as proposed by Trump was also part of JFK&rsquo;s immigration proposal: &ldquo;Immigrants would still be given tests for health, intelligence, morality, and security.&rdquo; The conditions established by law at that time and proposed by JFK for admission of such aliens are consistent with the requirements and restrictions proposed by Trump for admission of refugees.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</span></span></p>

<p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">JFK (and others, including Hubert Humphrey) co-sponsored a bill which led to the Communist Control Act of 1954 (68 Stat. 775) which outlawed the Communist Party. Many, including liberals, have asserted that the provisions and legal findings as to Communism in the Immigration and Nationality Act of 1952 and the Communist Control Act of 1954 should be applied to Islamic ideology and Islamic immigration. They generally rely on the provisions in those acts which find that organizations with the objective of control, takeover, or overthrow of the U.S. government by force or violence and organizations which acknowledge no constitutional statutory limitations upon its conduct or upon that of its members should be considered a clear and present danger. In <a href="http://www.enotes.com/major-acts-congress/communist-control-act/">a&nbsp;2009 article</a>, Carl Auerbach, a liberal and a former constitutional law professor and dean at the University of Minnesota Law School , wrote that Senator Humphrey &ldquo;believed that liberals should take the lead in fighting Communism as well as all other totalitarian creeds and movements.&rdquo; Auerbach stated further in that article: &ldquo;Many nations have laws outlawing totalitarian organizations. The United States may have to take a position on whether democratic principles give legitimacy to Muslim fundamentalist movements, such as those in Algeria and Pakistan, that seek political power by legal means only to crush democracy. The Communist Control Act is a precedent for not tolerating intolerant political movements.&rdquo;</span></span></p>

<p><span style="font-size:14px;"><span style="font-family:times new roman,times,serif;">The decision to be made by Trump, and perhaps Congress, is the extent to which proposed immigrants will be allowed entry based on the priorities recommended by JFK and denied entry based upon their adherence to an ideology which is inconsistent with the principles of the Constitution and/or which poses an unacceptable security risk. Democrats who voted for President Trump will surely feel vindicated as he follows key provisions of the immigration pathway recommended by President Kennedy.&nbsp; &nbsp;&nbsp;</span></span></p></div>

        <!-- stopprint -->
                <!--<div id='div-gpt-ad-1345489840937-4' style='text-align:center;'>
			<script type='text/javascript'>
				//googletag.cmd.push(function() { googletag.display('div-gpt-ad-1345489840937-4'); });
			</script>
		</div>  -->
		
				<div class="social_tools">

			<!-- SHARE -->
			<span>
				<a href="http://www.addthis.com/bookmark.php" style="text-decoration:none;" onmouseover="return addthis_open(this, '', 'http://www.americanthinker.com/articles/2017/01/why_jfk_would_endorse_president_trumps_immigration_proposals.html', 'JFK+was+so+concerned+about+immigration+that+he+wrote+A+Nation+of+Immigrants+in+1958.+His+book+was+expanded+and+republished+posthumously+in+1964.+In+his+Presidential+Message+to+Congress+of+July+23%2C+1963%2C+JFK+recommended+replacement+of+the+%26ldquo%3Bnatio...');" onmouseout="addthis_close();" onclick="return addthis_sendto();"><img class="icon" src="http://s7.addthis.com/static/btn/sm-plus.gif" height="14" border="0" alt="Share" /> Share</a>			</span>

			<span class="separator">|</span>

			<!-- TWEET BUTTON -->
			<span class="addthis_toolbox addthis_default_style">
				<a class="addthis_button_twitter">&nbsp;Twitter</a>
			</span>

			<span class="separator">|</span>
			
			<!-- FACEBOOK SHARE -->
			<span class="addthis_toolbox addthis_default_style">
				<a class="addthis_button_facebook">&nbsp;Facebook</a>
			</span>

			<span class="separator">|</span>

			<!-- COMMENTS -->
			<span>
				<img class="icon" src="/assets/images/comments.png" height="16" /> <a href="/articles/2017/01/why_jfk_would_endorse_president_trumps_immigration_proposals_comments.html#disqus_thread" data-disqus-identifier="200120495"> Comments</a>
			</span>

			<span class="separator print">|</span>

			<!-- PRINT -->
			<span class="print">
				<a href="javascript:void(0);" onclick="print();"><img src="/assets/images/icon-print.png"  /> Print</a>
			</span>

			<span class="separator email">|</span>
			
			<!-- EMAIL -->
			<span class="addthis_toolbox addthis_default_style email">
				<a class="addthis_button_email"> &nbsp;Email</a>
			</span>

		</div>                
				<div id="related-footer"></div>
        
		<div id='div-gpt-ad-1345489840937-8' style='width:1px; height:1px;'>
			<script type='text/javascript'>
				googletag.cmd.push(function() { googletag.display('div-gpt-ad-1345489840937-8'); });
			</script>
		</div>

		<script type="text/javascript">
			/* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
			var disqus_shortname = 'americanthinker'; // required: replace example with your forum shortname

			/* * * DON'T EDIT BELOW THIS LINE * * */
			(function () {
				var s = document.createElement('script'); s.async = true;
				s.type = 'text/javascript';
				s.src = 'http://' + disqus_shortname + '.disqus.com/count.js';
				(document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
			}());
		</script>

	</div>

	<div class="column_364">

		<!-- <script type="text/javascript" src="/assets/js/widgets/recent_videos.js"></script> -->

		<div id='div-gpt-ad-1457979917706-0' style='height:100px; width:365px; margin-top:20px;'>
		<script type='text/javascript'>
		googletag.cmd.push(function() { googletag.display('div-gpt-ad-1457979917706-0'); });
		</script>
		</div> 


		<div class="side_links">

			<script type="text/javascript" src="/assets/js/widgets/recent_articles.js"></script>
			<script type="text/javascript" src="/assets/js/widgets/recent_blog_posts.js"></script>
			<script type="text/javascript" src="/assets/js/widgets/monthly_article_archives.js"></script>

		</div>

				<div class="follow_us">

			<h3>FOLLOW US ON</h3>

			<div class="social_buttons">
				<a href="https://www.facebook.com/pages/American-Thinker/144317282271701"><img src="/assets/images/ICON-FACEBOOK.gif" alt="American Thinker on Facebook" /></a><a href="https://twitter.com/#!/AmericanThinker"><img src="/assets/images/ICON-TWITTER.gif" alt="American Thinker on Twitter" /></a>
			</div>

			<a class="newsletter" href="javascript:void window.open('http://americanthinker.com/static/newsletter.html','','width=400,height=400,scrollbars=yes');"><img src="/assets/images/at-newsletter-signup-graphic.gif" alt="American Thinker Newsletter Signup" /></a>

		</div>
				<div class="side_ads">
			<!-- AT_160_600 -->
			<div id='div-gpt-ad-1345489840937-0' style='width:160px; height:600px; margin-top: 10px;'>
				<script type='text/javascript'>
					if(page_width_onload >= 640) {
						googletag.cmd.push(function() { googletag.display('div-gpt-ad-1345489840937-0'); });
					}
				</script>
			</div>
						
			<div id='div-gpt-ad-1455834208841-3' style='margin-top:10px; height:600px; width:160px;'>
				<script type="text/javascript">
					if(page_width_onload >= 640) {
						googletag.cmd.push(function() { googletag.display('div-gpt-ad-1455834208841-3'); });
					}
				</script>				
			</div>
            		</div>
		

	    <div class="videos_widget">
       		<div class="title"><h3>RECENT VIDEOS</h3><div class="more"><a href="/video/">More Videos »</a></div></div>
            <div class="items" style="margin-left:0px;">
				<!--<div style="margin-top:6px; margin-left:auto; margin-right:auto;" class="ndn_embed" data-config-widget-id="28991" data-config-type="VideoLauncher/Slider300x250" data-config-tracking-group="92095"></div>-->
				<div style="margin-top:6px; margin-left:auto; margin-right:auto;" class="ndn_embed" data-config-widget-id="28991" data-config-type="VideoLauncher/Slider300x250" data-config-tracking-group="92095"></div>
				
           	</div>
        </div> 
		<script type="text/javascript">var _ndnq = _ndnq || []; _ndnq.push(['embed']);</script>
		
		<div id="related-sidebar"></div> 


	</div>

</main>

<!-- ValueClick Media In-Text CODE for American Thinker -->
<script src="http://cdn.fastclick.net/js/adcodes/pubcode.min.js"></script><script type="text/javascript">document.write('<scr' + 'ipt type="text/javascript">(function () {try{VCM.media.render({sid:31644,media_id:12,media_type:14,version:"1.2"});} catch(e){document.write(\'<scr\' + \'ipt type="text/javascript" src="http://media.fastclick.net/w/get.media?sid=31644&m=12&tp=14&d=j&t=n&exc=1"></scr\' + \'ipt>\');}}());</scr' + 'ipt>');</script><noscript><a href="http://media.fastclick.net/w/click.here?sid=31644&m=12&c=1" target="_blank"><img src="http://media.fastclick.net/w/get.media?sid=31644&m=12&tp=14&d=s&c=1&vcm_acv=1.2" width=0 height=0 border=1></a></noscript>
<!-- ValueClick Media In-Text CODE for American Thinker -->

		<footer role="contentinfo">

			<span class="links">
				<a href="/static/about_us.html">About Us</a> | 
				<a href="/static/contact_information.html">Contact</a> | 
				<a href="/static/privacy_policy.html">Privacy Policy</a> | 
				<a href="/static/rss_syndication.html">RSS Syndication</a>
			</span>

			<span class="copyright">&copy; American Thinker 2017</span>

			<div class="bottom_banner_ad">
				<div id='div-gpt-ad-1345489840937-6' style='width:728px; height:90px; margin: 10px auto 0;'>
					<script type='text/javascript'>
						if(page_width_onload >= 768) {
							googletag.cmd.push(function() { googletag.display('div-gpt-ad-1345489840937-6'); });
						}
					</script>
				</div>
			</div>

		</footer>

		<!-- AT_1_by_1_welcome -->
			<div id='div-gpt-ad-1345489840937-2' style='width:1px; height:1px;'>
				<script type='text/javascript'>
					googletag.cmd.push(function() { googletag.display('div-gpt-ad-1345489840937-2'); });
				</script>
			</div>
		<!-- END AT_1_by_1_welcome -->

		<!-- Start Quantcast tag -->
			<script type="text/javascript">
				_qoptions={
					qacct:"p-9bKF-NgTuSFM6"
				};
			</script>
			<script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>
			<noscript>
				<img src="http://pixel.quantserve.com/pixel/p-9bKF-NgTuSFM6.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
			</noscript>
		<!-- End Quantcast tag -->

		<!-- Addthis -->
			<script type="text/javascript" src="http://s7.addthis.com/js/250/addthis_widget.js#pubid=aramanujan"></script>

			<script>
				var addthis_share = { email_template: "new_template" }
			</script>



	</div></body>

</html>